Community
cancel
Showing results for 
Search instead for 
Did you mean: 
161 Views

Disable "MKL POISSON LIBRARY WARNING:"

Jump to solution
Hello,

I'm using s_Helmholtz_2D routine to solve my Poisson equation. I specify Neumann boundary conditions for all boundaries and receive this warning:

MKL POISSON LIBRARY WARNING:
The problem is degenerate up to rounding errors! The approximate solution
that provides the minimal Euclidean norm of the solution will be computed...

Yes, I totally understand that and all works fine. So, is there a way do disable this warning? It's just spamming output of my utility.
0 Kudos
1 Solution
161 Views
Hi,
Try to set ipar[2]=0.
With best regards,
Alexander Kalinkin

View solution in original post

4 Replies
162 Views
Hi,
Try to set ipar[2]=0.
With best regards,
Alexander Kalinkin

View solution in original post

161 Views
It works! Thanks a lot!

And by the way: I wouldn't have asked such a simple question if there was convenient search on the reference, really.
161 Views
You are welcome! :)
This parameter described in common parameters, chapter 13 "Partial differential equations support" of
Intel Math Kernel Library ReferenceManual.
With best regards,
Alexander Kalinkin
Camilo_P_
Beginner
161 Views

The instructions given by Alexander Kalinkin are for C++ or a zero based language. For fortran you need to set ipar(3) =0.

 

Reply