Community
cancel
Showing results for 
Search instead for 
Did you mean: 
kangshiyin
Beginner
79 Views

Option '-mkl' can't do static link in Intel Composer 2013update1

I found -mkl option can't do static link for MKL in Intel Composer 2013update1. But it works well in 2011_sp1_update3.

The folloiwing post in the Forum 'Intel® C++ Compiler ' contains the compling and linking commands for this issue.

http://software.intel.com/en-us/forums/topic/347295

Is this a bug for 2013? Will -mkl support static link later?

Thanks.

0 Kudos
3 Replies
Gennady_F_Intel
Moderator
79 Views

I don't see the problem on my side with Composer 2013 ( Package ID: l_ccompxe_2013.1.117 l_ccompxe_13.0.1.117 and w_ccompxe_p_13.0.1.119 ) I checked how it works on linux and windows 64 bit systems. the compilation line: icl /w /Fo /I"$(LINCL)" /Qmkl:parallel /Fedgemm.exe dgemm.cpp or icc dgemm.cpp -I${MKL_INCL} -mkl=sequential -o dgemm.out it works for both systems. --Gennady
Tom_Truscott
Beginner
79 Views

Try putting the -mkl=sequential (or similar) option at the end of the command line (in particular, after any .o files). If that works, then it seems like an options processing deficiency to me.
David_W_7
Beginner
79 Views

I am having the same problem. The exact code worked fine with 2011 update 3, but now MKL works only with a dynamic link. When I use a static link (which I require) I get lots of errors about the unavailability of BLAS and LAPACK. I've tried both -mkl=parallel and -mkl=sequential and neither helps much. Thanks! David
Reply