Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.

Stack trace terminated abnormally

felipin85
Beginner
631 Views
Hi everybody! I'm using Intel Fortran Compiler for Linux, Ubuntu 10.10 64 bits. I have a problem with a subroutine, I get the following message:

Comenzamos a calcular los desplazamientos. Ten paciencia
Tiempo de calculo = 0.0199999999999996 segundos.
SALI DE LAS ECUACIONES DE MINDLIN
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source

Stack trace terminated abnormally.






In the execute of the subroutine EcuacionesMindlinEmpotradoTodo.f90, the subroutine call to SPARSE, SPARSE using mkl_dss,when the main program ends appears the bug. Could someone explain where I have the bug? Thanks.

Regards,

Felipe Rodrguez
0 Kudos
5 Replies
mecej4
Black Belt
631 Views
You did not post all the files needed to build the program. The following routines are missing:

REORDENACIONGIROSDESPLAZAMIENTOS
PASO
GENERACIONMALLADO
CONDICIONCONTORNO
VECTORCARGAS
REORDENACIONSIMPLE
MOMENTOSMOD

Please also state the version of the compiler (ifort -V), the compilation options used, and supply any data needed to run the program.
0 Kudos
mecej4
Black Belt
631 Views
Your program requires more stack space than the default. Lookup "ulimit" for how to allocate stack limits. You will also need to use the "-traceback" compiler option to help with debugging your program. Other useful information is provided in this link:

determining-root-cause-of-sigsegv-or-sigbus-errors
0 Kudos
felipin85
Beginner
631 Views
First, Mecej4 very thanks for your help. But, I have a question, how change the option ulimit?
In the link talks of change bash, but, I don't know if It is change the file bashrc or write in the terminal.

Sorry for the inconvenience
Thanks
0 Kudos
mecej4
Black Belt
631 Views
Putting in the ulimit stack option in .bashrc makes the option apply to every Bash session; running the command in a shell makes it apply only to that session. Take your pick.

You may want to consider two changes: (i) Do not use automatic allocation on the stack for very large arrays; (ii) remove or comment out the Gnuplot calls and messages until your program is working correctly.
0 Kudos
felipin85
Beginner
631 Views
Sincerely, thank you very much. I will do as suggested.
0 Kudos
Reply