Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.

mkl_intel_thread.1.dll was not found

eliopoulos
Beginner
2,369 Views

I have recently bought and installed Intel® oneAPI Base & HPC Toolkit (Single-Node) and I have a problem using the Math Kernel Library with the Visual Studio 2017 Professional. It builds the solution without any issue but when I run the application, an error occurs: "mkl_intel_thread.1.dll was not found". Could you please send me the solution?
Best regards,
Dr. Elias N. Eliopoulos
University of Patras
Department of Mechanical Engineering and Aeronautics
e-mail: eliopoulos@upatras.gr

0 Kudos
1 Solution
mecej4
Black Belt
2,087 Views

We do not know some important details of how you attempt to run, but here is a suggestion to try.

Open an Intel OneAPI command prompt from the Windows Start menu. Navigate to the directory where the EXE that you built is located, and run the EXE there.

If that works, you can make a habit of running Visual Studio from that command window instead of from another shortcut. 

You could also adjust the system-wide environment, but there are several drawbacks to doing so.

View solution in original post

11 Replies
MRajesh_intel
Moderator
2,313 Views

Hi,

 

Can you please share the oneAPI version installed and try setting these variables in your visual studio:

 

Environment Variable in the debugging section:

For x64: 

PATH=C:\Program Files (x86)\Intel\oneAPI\compiler\2021.2.0\windows\redist\intel64_win\compiler;C:\Program Files (x86)\Intel\oneAPI\mkl\2021.2.0\redist\intel64;%PATH%

 

For x86:

PATH=C:\Program Files (x86)\Intel\oneAPI\compiler\2021.2.0\windows\redist\ia32_win\compiler;C:\Program Files (x86)\Intel\oneAPI\mkl\2021.2.0\redist\ia32;%PATH%

 

Debug Mode: x64, x86 accordingly.

 

Intel Libraries for oneAPI: Use oneMKL and set an appropriate option.

 

Please let us know if you have any issues.

 

Regards

Rajesh.

 

 

eliopoulos
Beginner
2,275 Views

Dear Rajesh,

Thank you for your quick answer. Unfortunately, your solution does not work.

Best regards,

Elias

MRajesh_intel
Moderator
2,253 Views

Hi,


Can you please share the oneAPI and visual studio version along with screenshot of the error and the visual studio settings used?


Thanks

Rajesh,


MRajesh_intel
Moderator
2,199 Views

Hi,


Can you please share any updates regarding your issue?


Regards

Rajesh.


eliopoulos
Beginner
2,188 Views

Dear Rajesh,

The problem remains, see the attached file. I assume I do not set the environment variables correctly. I have installed Visual Studio 2019 Professional, Intel Parallel Studio XE 2020 Update 4, Intel oneAPI Base Toolkit and Intel oneAPI HPC Toolkit ver. 2021.2. Could you please tell me how to set the environment variables for the Intel oneAPI Math Kernel Library correctly?

Thank you for your interest,

Elias

mecej4
Black Belt
2,088 Views

We do not know some important details of how you attempt to run, but here is a suggestion to try.

Open an Intel OneAPI command prompt from the Windows Start menu. Navigate to the directory where the EXE that you built is located, and run the EXE there.

If that works, you can make a habit of running Visual Studio from that command window instead of from another shortcut. 

You could also adjust the system-wide environment, but there are several drawbacks to doing so.

eliopoulos
Beginner
2,077 Views

Dear mecej4,

it works! Thank you very much.

Best regards,

Elias

MRajesh_intel
Moderator
2,110 Views

Hi,

 

Please refer to the below images for setting the required environment and let us know if you face the same issue. I have set the environment for x64 mode. Add the above mentioned path for x64 in the environment setting.

 

Regards

Rajesh.

 

eliopoulos
Beginner
2,095 Views

Hi,

First of all, I cannot find the MKL SAMPLE Property Pages. Then, I think I need the full PATHS for the Environment and the Evaluated value. In case you have not understood, I work with FORTRAN, see the attached file.

Best regards,

Elias

MRajesh_intel
Moderator
2,059 Views

Hi,

 

In the case of FORTRAN try enabling the oneMKL in the Libraries section and also if you enable it /Qmkl will be set automatically in your Visual Studio.

 

 

If you still face the issue try these steps:

  • Open the project property pages (Alt + Enter)
  • Change the Configuration to Debug (On the top left corner)
  • On the left window, under the Configuration properties tab, click on Debugging.
  • Under the Action tab, click on the Environment field and add the following:
    PATH=C:\Program Files (x86)\Intel\oneAPI\mkl\latest\redist\intel64;%PATH%

 

 

Save the changes and run your executable. Let us know if you face any issues.

 

Regards

Rajesh.

 

MRajesh_intel
Moderator
1,872 Views

Hi,


Thanks for accepting as a solution.


As this issue has been resolved, we will no longer respond to this thread. If you require any additional assistance from Intel, please start a new thread. Any further interaction in this thread will be considered community only.


Have a Good day.


Regards

Rajesh



Reply