Community
cancel
Showing results for 
Search instead for 
Did you mean: 
76 Views

trouble when running the fft examples

As the subject says. I have sourced the intel64 .sh file...libiomp5.dyld is in /opt/intel/Compiler/11.1/088/lib
I'm stumped (as usual!).

Here's what I get in directory /opt/intel/Compiler/11.1/088/Frameworks/mkl/examples/fftw3xf

bash-3.2$ make libem64t interface=ilp64
make lib _IA=em64t
rm -rf ./_results/intel_ilp64_parallel_em64t
test -d ./_results/intel_ilp64_parallel_em64t || mkdir -p ./_results/intel_ilp64_parallel_em64t
ifort -vec-report0 -i8 -I../../include/fftw -c source/mkl_fftw_examples_support.f -o _results/intel_ilp64_parallel_em64t/mkl_fftw_examples_support.o
ifort -vec-report0 -i8 -I../../include/fftw source/complex_1d_double_ex1.f _results/intel_ilp64_parallel_em64t/mkl_fftw_examples_support.o -L../../lib/em64t -lmkl_intel_ilp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -o _results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.out
DYLD_LIBRARY_PATH="../../lib/em64t:$DYLD_LIBRARY_PATH" _results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.out >_results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.res
dyld: Library not loaded: libiomp5.dylib
Referenced from: /opt/intel/Compiler/11.1/088/Frameworks/mkl/examples/fftw3xf/_results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.out
Reason: image not found
/bin/sh: line 1: 721 Trace/BPT trap DYLD_LIBRARY_PATH="../../lib/em64t:$DYLD_LIBRARY_PATH" _results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.out > _results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.res
make[1]: *** [_results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.res] Error 133
rm _results/intel_ilp64_parallel_em64t/mkl_fftw_examples_support.o
make: *** [libem64t] Error 2
bash-3.2$

Thanks for setting me straight.
0 Kudos
5 Replies
barragan_villanueva_
Valued Contributor I
76 Views

Hi,

It's strange because libiomp5.dylib (together with all MKL-libraries) should be located in the
/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t
directory
Artem_V_Intel
Employee
76 Views

Hi,
It's wrong. libiomp5.dylib is located in the/opt/intel/Compiler/11.1/088/lib as Peter mentioned, because only Professional Compiler distribution exist under Mac OS X operating system.
Best regards,
Artem
Artem_V_Intel
Employee
76 Views

Hello Peter,
I tried to follow your steps and doesn't obtain any issues. Please see the log of my actions below:
# bash
bash-3.2# source /opt/intel/Compiler/11.1/088/bin/ifortvars.sh intel64
bash-3.2# make libem64t interface=ilp64
make lib _IA=em64t
rm -rf ./_results/intel_ilp64_parallel_em64t
test -d ./_results/intel_ilp64_parallel_em64t || mkdir -p ./_results/intel_ilp64_parallel_em64t
ifort -vec-report0 -i8 -I/opt/intel/Compiler/11.1/088/Frameworks/mkl/include/fftw -c source/mkl_fftw_examples_support.f -o _results/intel_ilp64_parallel_em64t/mkl_fftw_examples_support.o
ifort -vec-report0 -i8 -I/opt/intel/Compiler/11.1/088/Frameworks/mkl/include/fftw source/complex_1d_double_ex1.f _results/intel_ilp64_parallel_em64t/mkl_fftw_examples_support.o -L/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t -lmkl_intel_ilp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -o _results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.out
DYLD_LIBRARY_PATH="/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t:$DYLD_LIBRARY_PATH" _results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.out >_results/intel_ilp64_parallel_em64t/complex_1d_double_ex1.res
ifort -vec-report0 -i8 -I/opt/intel/Compiler/11.1/088/Frameworks/mkl/include/fftw
etc etc...
Did you change environment after sourcing ifortvars.sh?
May be your installation of Intel Fortran Compiler is broken. Try to reinstall it.
Best regards,
Artem
barragan_villanueva_
Valued Contributor I
76 Views

Well, according to the following used path -L../../lib/em64t it means that MKLROOT was not set before run examples
76 Views

Thanks for the replies guys...I must hang my head in shame !

I was trying the examples under opt and was sourcing the environment script as me and then
using sudo to do the make...DUH!
Reply