Intel® oneAPI Threading Building Blocks
Ask questions and share information about adding parallelism to your applications when using this threading library.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

Segmentation fault when using fgt2xml

Senyai
Beginner
892 Views

Hi! I'm getting segmentation fault when using fgt2xml (or fgt2xml_debug). `0x000055555564220f in fgt_record_processor::dump_trace (this=0x7fffffffd7e0) at /localdisk/jenkins/workspace/FGA_Linux_build/fgatool/src/collector/src/fgt2xml/fgt_record_processor.cpp:1089`. Is there any chance to open source this tool? Otherwise I have no idea how to find out the root cause of the issue.

0 Kudos
8 Replies
ShivaniK_Intel
Moderator
876 Views


Hi,


Thanks for reaching out to us.


Could you please provide us your system environment details(OS version)?


Could you also provide us the version of Intel one API you have been using and complete error log?


Thanks & Regards

Shivani


Senyai
Beginner
822 Views
Sorry for delayed response. I'm using docker image `docker pull intel/oneapi:latest`.
ShivaniK_Intel
Moderator
836 Views

Hi,


As we didn't hear back from you, Is your issue resolved? If not, please provide the details that have been asked in my previous post.


Thanks & Regards

Shivani


ShivaniK_Intel
Moderator
809 Views

Hi,


Could you please provide us the complete error log to investigate more on your issue?


Thanks & Regards

Shivani




ShivaniK_Intel
Moderator
770 Views

Hi,


We are working on it and will get back to you soon.


Thanks & Regards

Shivani


Senyai
Beginner
757 Views

I have an idea now of what is going on. TBB_USE_PROFILING_TOOLS was enabled on tbb::flow code only and not in other files files that use tbb. After enabling TBB_USE_PROFILING_TOOLS globally, I was able to get valid fgt2xml output. Anyway, segmentation fault must be fixed.

Vasanth_T_Intel
Employee
710 Views

Hi,

Thanks for providing the zip file of the FGT traces and triaging the possible reason as to why this might be happening. This will help us find a fix  when only partial set of files are compiled with TBB_USE_PROFILING_TOOLS.

--Vasanth

Reply