Intel® oneAPI Threading Building Blocks
Ask questions and share information about adding parallelism to your applications when using this threading library.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

TTB on MacOS - first try

Simeon
Beginner
153 Views

Hi guys,

I've downloaded tbb22 and untar it. I've also exported LIBRARY_PATH to properly refer precompiled dynamic libraries under /ia32/cc4.0.1_os10.4.9/lib.

I could successfully build the example /parallel_for/game_of_live.NET. When I execute it I get the output:

./game_of_life 2:4 -t 5

dyld: Library not loaded: libtbb.dylib

Referenced from: /Users/simeonmitev/projects/tbb22_20090809oss/examples/parallel_for/game_of_life.NET/./game_of_life

Reason: image not found

make: *** [test] Trace/BPT trap

What could be the reason for that?




0 Kudos
2 Replies
Simeon
Beginner
153 Views
Quoting - Simeon

Hi guys,

I've downloaded tbb22 and untar it. I've also exported LIBRARY_PATH to properly refer precompiled dynamic libraries under /ia32/cc4.0.1_os10.4.9/lib.

I could successfully build the example /parallel_for/game_of_live.NET. When I execute it I get the output:

./parallel_preorder

dyld: Library not loaded: libtbb.dylib

Referenced from: /Users/simeonmitev/projects/tbb22_20090809oss/examples/parallel_do/parallel_preorder/./parallel_preorder

Reason: image not found

make: *** [test] Trace/BPT trap

What could be the reason for that?





I've found the problem. The dynamic library file was not viewable by the binary application. Now it works:

0.366709 seconds using 1 threads (average of 202.92 nodes in root_set)
0.195334 seconds using 2 threads (average of 202.92 nodes in root_set)
0.199316 seconds using 3 threads (average of 202.92 nodes in root_set)
0.200013 seconds using 4 threads (average of 202.92 nodes in root_set)


Alexey_K_Intel3
Employee
153 Views
Quoting - Simeon
I've found the problem. The dynamic library file was not viewable by the binary application. Now it works:

For sake of further readers, could you specify what exactly you did to solve the problem? Was it setting DYLD_LIBRARY_PATH, or "sourcing" an appropriate tbbvars commandfile?
Reply