Intel® oneAPI Threading Building Blocks
Ask questions and share information about adding parallelism to your applications when using this threading library.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Trouble running sample program

blork98
Beginner
64 Views
Hello,

I have just downloaded the Commercial-Aligned Open Source version of Intel TBB. I tried running the sample program Sub_String_Finder. The project compiles and links succesfully, however there is a warning ( Command line warning D9035 : option 'Wp64' has been deprecated and will be removed in a future release ) which does not seem serious.

Anyway, the problem I am facing is when I actually run the program in debug mode it seems to go into an infinite loop or something when it reaches this line of code:

[cpp]parallel_for(blocked_range(0, num_elem ),
               SubStringFinder( to_scan, max, pos ) );[/cpp]


I am just wondering if this is a problem with my machine or is anyone else facing it? I am using a dual core windows XP machine and am using Microsoft Visual C++ Express 2008. I am pretty sure I am using the correct lib (C:\\Intel TBB 3.0174\\lib\\ia32\\vc9) and dll (C:\\Intel TBB 3.0174\\bin\\ia32\\vc9).

My machine is a Centrino Duo using Windows XP. I am using Microsoft Visual C++ Express 2008 ( which corresponds to vc 9 i am pretty sure ). I am just wondering if there is anything I am missing, like missing compiler options etc. I have tried building the sample by creating my own project as well as using the project files that came with the download.

thanks


0 Kudos
1 Reply
Kirill_R_Intel
Employee
64 Views
Hello blork98,

I've installed the same setup: WinXP, VS2008 Express, TBB U6 tbb30_174oss. And I can reproduce your problem. The warning: "warning D9035 : option 'Wp64' has been deprecated and will be removed in a future release" can be removed by switching the following setting to "No":

Project Properties->Configuration Properties->C/C++->General
->Detect 64-bit Portability Issues

I noticed that the sample looks hanging up in this exact loop. I thought there is a real problem, but than noticed that if I decrease value of "N" variable it becomes responsive. Amount of work increases exponentially. It looks like default 23 is too much for my laptop. I tried 5, than 15 and all worked fine. 20 worked but took some time. So I think I just wasn't patient enough to wait when N is 23. Just decrease the value - this should work.

Regards,
Kirill
Reply