Intel® oneAPI Threading Building Blocks
Ask questions and share information about adding parallelism to your applications when using this threading library.
2430 Discussions

VS upgrades, OpenCL, System Studio 2020, flow_graph_opencl_node.h

WCost1
Beginner
329 Views

Hi,

I'm working on the simplest example of an OpenCL flow graph. Compiling fails when looking for async_msg, even with the calls to anything OpenCL are commented out.

#define TBB_PREVIEW_FLOW_GRAPH_NODES 1
#define TBB_PREVIEW_FLOW_GRAPH_FEATURES 1

#include "tbb/flow_graph.h"
#include "tbb/flow_graph_opencl_node.h"

void testfunc()
{
    tbb::flow::graph g;
 
    bool has_been_run = false;

    //using buffer_t = tbb::flow::opencl_buffer<cl_char>;
}

Error        async_msg is not a template    my_prog    C:\Program Files (x86)\IntelSWTools\system_studio_2020\compilers_and_libraries_2020.0.166\windows\tbb\include\tbb\flow_graph_opencl_node.h    354    

... and many more.

If I comment out the header file   //#include "tbb/flow_graph_opencl_node.h" then my program compiles again.

Maybe the installation is incomplete. I was using VS 2019 16.4.5 but it said to upgrade because of the an OpenCL requirement. That broke the Intel installations. After a few iterations of running the System Studio 2020 installer, and selecting anything "OpenCL", it stopped adding anything meaning it thinks everything is complete. Eventually I ran several  Visual Studio Extension Intallers (*.vsix) in a System Studio 2020 subfolder and the Intel Compiler 19.1 and the Intel libraries (TBB, ...) where available again in the project properties.

Any ideas on what needs fixing? Files, paths, env vars, compiler settings, .... ?

 

 

 

0 Kudos
0 Replies
Reply