Community
cancel
Showing results for 
Search instead for 
Did you mean: 
_heinz
Beginner
111 Views

msvs_plugin_20080610 under Vista64

Hi,

I have a starting problem with TBB and msvs_plugin under Vista64. After doing the following steps, the registration is not succeeded in VS2005 and VS2008.

Ididdownload tbb21_012oss_win.zip and additional msvs_plugin_20080610.zip.

1. I unzipped tbb21_012oss.zip to C:\I\INTEL\tbb21_012oss the directory where TBB should reside for me.

2. I set the environvariable TBB21_INSTALL_DIR C:\I\INTEL\tbb21_012oss

3. I set the PATH to PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\In
tel\DMIX;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program
Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\TortoiseSVN\bin
;C:\I\INTEL\tbb21_012oss

4. I unzipped the file msvs_plugin_20080610.zip to a working directory

5. I read the README file of the msvs_plugin

in the working directory I goto the directory msvs_plugin_20080610 and read the file "README".I can not use a normal win-Editor, so Iuse Visual Studio 200 Expressto open the file. After this I close Visual Studio and do the following steps from the README:

Because I donot have VS2003 I started with the point VS2005

- Microsoft* Visual Studio* 2005

1. Create or open the "\Visual Studio 2005\Addins"
folder.

2. Copy all files from msvs_plugin\vc8 into the above folder.

- Microsoft* Visual Studio* 2008

1. Create or open the "\Visual Studio 2008\Addins"
folder.

2. Copy all files from msvs_plugin\vc9 into the above folder.

To ensure that the registration succeeded, select Tools -> Add-in
Manager in the main Microsoft* Visual Studio* menu and check that the
TBB integration plug-in is listed in the table. Also, the list of
installed products, in the Microsoft* Visual Studio* Help -> About
dialog, should contain an entry for "TBB Integration".
----------------------------------------------------------------

I did as above described for VS2005 and VS2008, but when I started VS2005 or VS2008 I cant find that the msvs-plugin is listed anywhere, not in the main menue, not in Visual Studio* Help -> About
the Addins directorys are (have german versions of VS2005 and VS2008)

C:\Users\heinz\Documents\Visual Studio 2005\Addins

06.11.2008 20:48

.
06.11.2008 20:48 ..
09.06.2008 21:10 1.932 paths.xml
09.06.2008 20:32 1.910 tbb_integration_vc8.AddIn
09.06.2008 20:57 24.576 tbb_integration_vc8.dll
3 Datei(en), 28.418 Bytes

C:\Users\heinz\Documents\Visual Studio 2008\Addins

06.11.2008 20:51

.
06.11.2008 20:51 ..
09.06.2008 21:19 1.932 paths.xml
09.06.2008 20:30 1.910 tbb_integration_vc9.AddIn
09.06.2008 21:25 14.336 tbb_integration_vc9.dll
3 Datei(en), 18.178 Bytes

------------------------------------------------------------------------

A newstart of the system did not help anything.

Thanks for your help

0 Kudos
10 Replies
Elena_G_Intel
Employee
111 Views

Hi,
Please, check if the directories with the plug-in files are listed in "Environment | Add-in/Macros Security" Options (Tools->Options). Even if there are directories like %VSMYDOCUMENTS%Addins, please, add your directories directly (C:UsersheinzDocumentsVisual Studio 2005Addins and C:UsersheinzDocumentsVisual Studio 2008Addins) .
And also check if "Allow Add-in components to load" is checked.

_heinz
Beginner
111 Views

Hi,
Please, check if the directories with the plug-in files are listed in "Environment | Add-in/Macros Security" Options (Tools->Options). Even if there are directories like %VSMYDOCUMENTS%Addins, please, add your directories directly (C:UsersheinzDocumentsVisual Studio 2005Addins and C:UsersheinzDocumentsVisual Studio 2008Addins) .
And also check if "Allow Add-in components to load" is checked.

I don't forget to tell, Iuse VS2005 Express Edition, VS2008 Express Edition and Visual Studio 2008 Professional Edition(eval 90 days) parallel.

I have done as you recommended in VS2008 Professional, I can see "Intel Threading Building Blocks Integration" is shown in "About".

I loaded the project "fibonacci" from our examples and it compiled sucessful with VS2008 Professional, although in the "Solution Explorer" the submenu "Use Intel TBB" is not available(it is not shown, if I right click). So this is not functional, till now:

To enable TBB for a given C++ project, right-click on the project item
in the Microsoft* Visual Studio* Solution Explorer, and open the "Use
Intel TBB" sub-menu in the project context menu. The sub-menu
consists of the following items:

- The list of TBB versions the plugin is configured to use with.

Click the desired version you want to use with your project to
add the necessary parameters to the project settings.

I have seen TBB20 is used and not TBB21 as I expected. Both, TBB20_INSTALL_DIR and TBB21_INSTALL_DIR are defined as Environment variable, withits own directory. PATH is defined as %SystemRoot%system32;%SystemRoot%;%SystemRoot%System32Wbem;C:Program FilesIntelDMIX;C:Program Files (x86)ATI TechnologiesATI.ACECore-Static;C:Program Files (x86)Microsoft SQL Server90Toolsbinn;C:Program FilesTortoiseSVNbin;C:IINTELtbb21_012oss

Additional include directory is shown as $(TBB20_INSTALL_DIR)include
I did expected to see $(TBB21_INSTALL_DIR)include there.

Now to the Express versions. A side effect of all this we have done is: the fibonacci project can now sucessful compiled in both Express versions. This was notpossible before.How can we integrate the msvs_plugin into the Express versions ? The menu Tools-->Options -->Environment-->AddIn/Macrosecurity is not available there.

see Extras http://www.britta-d.de/images/vs/extras.jpg

and Optionen-->Umgebunghttp://www.britta-d.de/images/vs/extras_optionen.jpg

Elena_G_Intel
Employee
111 Views

Please, check if the plug-in is checked in Tools -> Add-in Manager table after you added path in Options.
"C:IINTELtbb21_012ossem64tvc8{9}bin"should be usedin the PATH environment variable instead of "C:IINTELtbb21_012oss".
Did you mean 'fibonacci' example from tbb21_012oss packagewhenwere saying about $(TBB20_INSTALL_DIR)include value? Actually, Additional Include Directory for this examplehas $(TBB21_INSTALL_DIR)include by default.
Unfortunately,there is an integration plug-in limitation- it doesn't workwith Express versions now.
_heinz
Beginner
111 Views

I added the two directories now to the path var. It shows now:

PATH=C:Windowssystem32;C:Windows;C:WindowsSystem32Wbem;C:Program FilesIn
telDMIX;C:Program Files (x86)ATI TechnologiesATI.ACECore-Static;C:Program
Files (x86)Microsoft SQL Server90Toolsbinn;C:Program FilesTortoiseSVNbin
;C:IINTELtbb21_012ossem64tvc9bin;C:IINTELtbb21_012ossem64tvc8bin

Sorry, I used the sample fibonacci from TBB20, I copied the sample tree to my working dir, as I installed TBB20 a while ago and forgot it. I'm sorry.

Now the sample fibonacci from TBB21compiled sucessful, ($(TBB21_INSTALL_DIR) is used.

1>------ Neues Erstellen gestartet: Projekt: fibonacci, Konfiguration: Release x64 ------

1>Die Zwischen- und Ausgabedateien fr das Projekt "fibonacci" mit der Konfiguration "Release|x64" werden gelscht.

1>Kompilieren...

1>Fibonacci.cpp

1>Verknpfen...

1>Das Manifest wird eingebettet...

1>Copying tbb.dll

1> 1 Datei(en) kopiert.

1>Das Buildprotokoll wurde unter "file://C:UsersheinzAppDataLocalTemptbb_examplesfibonaccix64ReleaseBuildLog.htm" gespeichert.

1>fibonacci - 0 Fehler, 0 Warnung(en)

========== Alles neu erstellen: 1 erfolgreich, Fehler bei 0, 0 bersprungen ==========

The additional menu is not shown: http://www.britta-d.de/images/vs/vs2008_nomenu.jpg

TBB Integration: http://www.britta-d.de/images/vs/vs2008_eval.jpg

Add-In/Macrosicherheit: http://www.britta-d.de/images/vs/vs2008_optionen_addin.jpg

Thank's Elena

_heinz
Beginner
111 Views

Elena_G_Intel
Employee
111 Views

You didn't write anything about Tools -> Add-in Manager table. Is it correct? I mean if the plug-in is checked in both "Availible Add-ins" (first) column and "Startup" (second) column. Could you also attach a screen shot with the dialog?
BTW, please, check if the main Project menu containsthe TBB Integration item.
_heinz
Beginner
111 Views

You didn't write anything about Tools -> Add-in Manager table. Is it correct? I mean if the plug-in is checked in both "Availible Add-ins" (first) column and "Startup" (second) column. Could you also attach a screen shot with the dialog?
BTW, please, check if the main Project menu containsthe TBB Integration item.

1. addin manager http://www.britta-d.de/images/vs/vs2008_addin_manager.jpg

2. main project http://www.britta-d.de/images/vs/vs2008_main_project.jpg

3. tbb21_install_dir http://www.britta-d.de/images/vs/tbb21_install_dir.jpg

4. using tbb21_install_dir http://www.britta-d.de/images/vs/using_tbb21_install_dir.jpg

Thanks in advance heinz

Elena_G_Intel
Employee
111 Views

Heinz,
Thanks for the screen shots you sent;they look good.But unfortunately it is not clear what is a reason ofthe integration menu absence. We are working on next version of plug-in that will provide more diagnostics of possible problems.I'll let you know when it will be available.Hope itwill help to catch the problem.
Thanks again.
Elena

shachris23
New Contributor I
111 Views

Heinz,
Thanks for the screen shots you sent;they look good.But unfortunately it is not clear what is a reason ofthe integration menu absence. We are working on next version of plug-in that will provide more diagnostics of possible problems.I'll let you know when it will be available.Hope itwill help to catch the problem.
Thanks again.
Elena

Hi Elena,

I'm a XP x64 user, and I just downloaded the plugin from http://www.threadingbuildingblocks.org/ver.php?fid=129

and I followed all the steps detailed under README.txt, but the TBB Intergation 2.x doesnt show up either.

Here's my platform info:

OS: WinXP x64 SP1

IDE: MSVC 2008 Professional SP1

TBB: ver 2.1

Plug-in Used: msvs_plugin_20080610

Thanks!

Elena_G_Intel
Employee
111 Views

Hi,

Please, check if there isTBB Integration line in Installed products list in Help -> About VS dialog and if it is checked in Tools -> Add-in Manager table. If no, please, add direct path to the plug-in dll into Add-in File Paths table (Tools -> Options -> Environment|Add-in/Macros Security).

Reply