Intel vPro® Platform
Intel Manageability Forum for Intel® EMA, AMT, SCS & Manageability Commander
2780 Discussions

In-Band SCCM Provisioning of Windows 7 Clients



---------- The Background ------------------

We've been using SCCM and vPro together for quite a long time now and I thought we'd been through all the teething issues etc Our environment has been stable and working without intervention for over 12 months.

We're now starting a Windows 7 roll out and for some reason I just cannot get Windows 7 clients to in-band provision whatever I try, re-image the same machine with Windows Vista and it all flows through correctly as it has been since we got setup. We have a certificate from an external CA etc, I'm not saying this is an issue with Windows 7 it could obviously be an issue with our W7 build!

I'm having the same issue on both HP dc7800's and dc7900's model machines and the issue is present whatever the machine is on our main office subnet or our IT setup vlan (I mention this because people have mentioned dhcp as a cause for this issue in one similar post). As I say I can take the exact same machine and install our Vista build on it and it will provision perfectly.

I have a collection setup that contains all machine awaiting provisioning and that collection has the enable provisioning box ticked in the collection settings.

We're running SCCM 2007 R2 on Server 2008 SP2 x64, database is on SQL 2008 SP1 on a Server 2008 SP2 x64

Out of Band provisioning is not enabled at all.

dc7800's were running AMT version 3.2.3 but I have also tried with 3.2.10 and the I have the latest HECI/LMS drivers from HP.

dc7900's were running AMT 5.0.3 and again I have tried with with 5.2.10 plus updates the HECI/LMS drivers to the latest from HP.

----------------- The Problem -----------------------

Machines have their controllers discovered with no problems.

This is what I get in the oobmgmt.log of the affected machines.



CAMTProvisionEndpoint::GetProvisionSettings: GetObject() failed: 80041002

!! AutoProvision policy disabled.


This repeats if it's automatic or if I trigger a provisioning attempt myself.----------------------- What I've tried so far (All made no difference) ------------------------------Full un provision etc including cmos battery.Installed Vista build on failing machine and process worked through perfectly so obviously somehting with W7 or my W7 build.Checked and double checked all SCCM vPro settings and can see nothing wrong and again setup works perfectly on same machines with Vista.I have tried turning off firewall on W7 client as I know it's one thing that's moved on a lot from vista.Deleted records from SCCM etc.Uninstalled ccm client etc and Reinstalled.Deleted and Recreated auto provisioning collection.Updated all drivers / bios and MEFirmware etc to the latest versions available from HPRestarted SCCM server.Loads of other fiddling!Any help or advice would be greatly appreciated!Adam
0 Kudos
0 Replies