Intel® vPro™ Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
2594 Discussions

ZTClocalagent activation issues

idata
Community Manager
1,333 Views

Hi all,

I am fairly new to vPro and trying to use the SDK on my AMT enabled HP 8440p laptop. I setup the basic AMT settings when I bought the computer in BIOS itself. Then when I started looking at the SDK, I downloaded it and when I perform discovery using ztclocalagent, it is successful. Here is a snippet of the output:

"

Intel AMT code versions:

 

Flash: 6.0.40

 

Netstack: 6.0.40

 

AMTApps: 6.0.40

 

AMT: 6.0.40

 

Sku: 24584

 

VendorID: 8086

 

Build Number: 1215

 

Recovery Version: 6.0.40

 

Recovery Build Num: 1215

 

Legacy Mode: False

 

Setup and Configuration:

 

Completed

Found 8 certificate hashes in following Handles:

 

0,1,2,3,4,5,6,7,"

However, when I try to use ZTClocalagent -activate, I run into errors and I am trying to get a feel what why I am getting these errors and how I can fix them:

Zero Touch Configuration:

 

enabled

Provisioning TLS Mode:

 

PKI

Failed performing Start Configuration command:

 

PT_STATUS_INVALID_PT_MODE: Command is not permitted in current operating mode.

Activate Intel AMT configuration:

 

Failure

Appreciate any inputs to help me with the same.

Regards,

Sudarsan VS.

0 Kudos
1 Solution
idata
Community Manager
125 Views

Sudarsan,

Are you using Windows Vista or 7? If so, make sure you launch your command prompt as Administrator when running the ZTClocalagent.

View solution in original post

1 Reply
idata
Community Manager
126 Views

Sudarsan,

Are you using Windows Vista or 7? If so, make sure you launch your command prompt as Administrator when running the ZTClocalagent.

Reply