Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

QSV dowsn't work, MSS2017 on Ubuntu 16

Milan_C_
Beginner
2,289 Views
Ubuntu 16.04.1 LTS
Linux Stream.local 4.4.0 #1 SMP Wed Sep 7 12:00:18 CEST 2016 x86_64 x86_64 x86_64 GNU/Linux
CPU0: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (family: 0x6, model: 0x3c, stepping: 0x3)
- Media Server Studio 2017, installation via install_IntelSDK.sh, all kernel patches installed
- cuda_8.0.27.1_linux

cat /etc/environment
# CUDA
CUDA_HOME=/usr/local/cuda
# Intel MediaSDK
LIBVA_DRIVER_NAME=iHD
LIBVA_DRIVERS_PATH=/opt/intel/mediasdk/lib64
PATH="/usr/local/cuda:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
LD_LIBRARY_PATH="/usr/local/cuda/lib64:/opt/intel/opencl:/usr/local/lib:/usr/lib64"
Linux Stream.local 4.4.0 #1 SMP Wed Sep 7 12:00:18 CEST 2016 x86_64 x86_64 x86_64 GNU/Linux

cd /opt/intel/mediasdk/opensource/libdrm/2.4.66-55964/
tar xf libdrm-2.4.66.tar.bz2
cd libdrm-2.4.66
./configure
make -j 8
make install
cd /opt/intel/mediasdk/opensource/libva/1.67.0.pre1-55964
tar xf libva-1.67.0.pre1.tar.bz2
cd libva-1.67.0.pre1
./configure --enable-static
make -j 8
make install
cd /opt/intel/mediasdk/opensource/mfx_dispatch/
mkdir build
cd build
cmake –D__ARCH:STRING=intel64 ../
make -j 8
# cat /usr/lib/pkgconfig/libmfx.pc
prefix=/opt/intel/mediasdk
exec_prefix=${prefix}
libdir=${prefix}/lib/lin_x64
includedir=${prefix}/include
Name: libmfx
Description: Intel Media Server Studio SDK
Version: 16.4.2
Requires:
Libs: -L${libdir} -lmfx -lva -lstdc++ -ldl -lva-drm -ldrm
Cflags: -I${includedir} -I/usr/local/include/libdrm

# ls -l /dev/dri
crwxrwxrwx 1 vlc vlc 226,   0 Sep 14 11:23 card0
crwxrwxrwx 1 vlc vlc 226,  64 Sep 14 11:23 controlD64
crwxrwxrwx 1 vlc vlc 226, 128 Sep 14 11:23 renderD128
 
# vainfo
error: can't connect to X server!
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.99 (libva 1.67.0.pre1)
vainfo: Driver version: 16.5.55964-ubit
vainfo: Supported profile and entrypoints
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: <unknown entrypoint>
      VAProfileH264ConstrainedBaseline: <unknown entrypoint>
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : <unknown entrypoint>
      VAProfileH264Main               : <unknown entrypoint>
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : <unknown entrypoint>
      VAProfileH264High               : <unknown entrypoint>
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : <unknown entrypoint>
      VAProfileVP9Profile0            : <unknown entrypoint>
      <unknown profile>               : VAEntrypointVideoProc
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileNone                   : <unknown entrypoint>?
 
+ ffmpeg compiled with --enable-libmfx alo ok.
All seems ok, but...
 
# /opt/intel/mediasdk/samples/sample_multi_transcode -i::h264 /opt/intel/mediasdk/samples/content/test_stream.264 -o::h264 /opt/intel/mediasdk/samples/content/test_out.h2$
Multi Transcoding Sample Version 7.0.16053497
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
Return on error: error code -2, /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK4/git/mdp_msdk-samples/samples/sample_multi_transcode/src/pipeline_transcode.cpp        3372
Return on error: error code -2, /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK4/git/mdp_msdk-samples/samples/sample_multi_transcode/src/sample_multi_transcode.cpp    277
 
ffmpeg -y -i "udp://@239.23.0.101:1234" -c:v h264_qsv -preset:v faster out.qsv.mp4
...
Input #0, mpegts, from 'udp://@239.23.0.101:1234':
  Duration: N/A, start: 36732.375211, bitrate: N/A
  Program 261
    Stream #0:0[0x7d1]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x7d2](cze): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 192 kb/s
    Stream #0:2[0x7d4](cze): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, mono, s16p, 64 kb/s (visual impaired)
    Stream #0:3[0x7d6](cze): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006) (hearing impaired)
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
[h264_qsv @ 0x40e9200] Error initializing the encoder
Output #0, mp4, to 'out.qsv.mp4':
    Stream #0:0: Unknown: none, SAR 1:1 DAR 0:0
    Metadata:
      encoder         : Lavc57.55.101 h264_qsv
    Stream #0:1(cze): Unknown: none
    Metadata:
      encoder         : Lavc57.55.101 aac
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> h264 (h264_qsv))
  Stream #0:1 -> #0:1 (mp2 (native) -> aac (native))
Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
 
0 Kudos
24 Replies
Milan_C_
Beginner
421 Views
huihai lu wrote:

I saw CUDA stuff in your post, so I assume you have a Nvidia graphic card in your system. Have you been able to enable both Nvidia graphic card and Intel GPU at the same time, and get MSS2017 to work?
 
Hello,
yes, I use QSV (i7-6700K) and nvenc (Quadro M4000) together in the same time without problems. MSS2017.
nvidia-370; cuda_8.0-44; nvidia_video_sdk_7.0.1; intel-opencl-16.5
0 Kudos
JONAS_O_
Beginner
421 Views

Manuel M. wrote:

Hi,

i have the same problem with ubuntu 16.04. I've installed everything as shown in the first post. But when i try to run the sample i got these error:

./sample_multi_transcode -i::h264 content/test_stream.264 -o::h264 /home/manuelmenz/out.h264 -hw -la
[sudo] password for manuelmenz: 
Multi Transcoding Sample Version 7.0.16053497

libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0

Return on error: error code -2,    /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK4/git/mdp_msdk-samples/samples/sample_multi_transcode/src/pipeline_transcode.cpp    3372

Return on error: error code -2,    /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK4/git/mdp_msdk-samples/samples/sample_multi_transcode/src/sample_multi_transcode.cpp    277

I can not download the sys_analyzer script because the server is unavailable...

Seeing the same problem, did you ever figure out what was wrong?

 

0 Kudos
spyer_s_
Beginner
421 Views

Hello,

i need support from the Community to install Intel Media Server 2017 oder 2017 R2 on my local Ubuntu.

Now, I install it successful on CentOS, but I need Ubuntu 14 or 16 not important.

if someone successfully installed Intel Media Server 2017 or 2017 R2 on my Ubuntu, then I am willing to pay for it

My last try I attached.

My Hardware: Intel i7 6700k, Asus Prime B250M-k

Best regards

0 Kudos
spyer_s_
Beginner
421 Views

Hello,

Now I am a step further and have problems with "vainfo not reporting codes entry points".

How can I solve this?
What do I have to consider afterwards if I want to install FFMPEG with QSV support?

Best regards

0 Kudos
Reply