Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Employee
76 Views

A dilemma: X display & Linux remote desktop & vainfo & Code Builder

hi,

I am accessing my Ubuntu from windows10 remotely (as this way describes, https://askubuntu.com/questions/592537/can-i-access-ubuntu-from-windows-remotely ). I have MSS installed. And using SSH terminal, vainfo and samples runs perfectly without problem. That's fine. However problems happens with remote desktop. And I find myself is in a dilemma - unset DISPLAY or export it?

Let me illustrate.

1. Problem begins with CodeBuilder of eclipse failure with error - "Failed to update machine list: Could not load required libraries: please make sure to set the correct path under the Code Builder for OpenCL preference page."

2. So, I went to check "python sys_analyzer_linux.py -v". And got this error, (please note: everything works find with SSH client terminal)

--------------------------
Hardware readiness checks:
--------------------------
 [ OK ] Processor name: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
 [ INFO ] Intel Processor
 [ INFO ] Processor brand: Core
 [ INFO ] Processor arch: Skylake
--------------------------
OS readiness checks:
--------------------------
 [ INFO ] GPU PCI id     : 1912
 [ INFO ] GPU description: SKL DT GT2
 [ OK ] GPU visible to OS
 [ INFO ] no nomodeset in GRUB cmdline (good)
 [ INFO ] Linux distro   : Ubuntu 16.04
 [ INFO ] Linux kernel   : 4.4.0
 [ INFO ] glibc version  : 2.23
 [ INFO ] Linux distro suitable for Generic install
 [ INFO ] gcc version    : 20160609 (>=4.8.2 suggested)
--------------------------
Media Server Studio Install:
--------------------------
 [ OK ] user in video group
 [ OK ] libva.so.1 found
 [ ERROR ] libva not loading Intel iHD
 [ ERROR ] vainfo not reporting codec entry points

 [ INFO ] i915 driver in use by Intel video adapter
 [ OK ] /dev/dri/renderD128 connects to Intel i915
--------------------------
Component Smoke Tests:
--------------------------
 [ OK ] Media SDK HW API level:1.23
 [ OK ] Media SDK SW API level:1.23
 [ OK ] OpenCL check:platform:Intel(R) OpenCL GPU OK CPU OK
platform:Experimental OpenCL 2.1 CPU Only Platform GPU OK CPU OK

3. Then I ran "vainfo" (also with remote desktop). Problem shows:

libva info: VA-API version 0.99.0
Xlib:  extension "XFree86-DRI" missing on display ":10.0".
libva info: va_getDriverName() returns -1

libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
vaInitialize failed with error code -1 (unknown libva error),exit

4. I noticed environment variable "DISPLAY=:10.0" is set with remote desktop. If unset DISPLAY, vainfo works without problem.

5. But I cannot unset DISPLAY or export "DISPLAY=:0.0". Because, if I unset it, eclipse would fail with X server connection issue:

Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Eclipse: Cannot open display:
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Eclipse: Cannot open display:
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused

Summary: the dilemma is, I have to keep "DISPLAY=:10.0" to start eclipse; while at the same time I have to disable it to make CodeBuilder work (it seems CodeBuilder depends on vainfo-like va driver access).

 

 

P.S. My system info:

Media SDK Client or Media Server Studio version installed: MediaServerStudioEssentials2017R3.tar.gz

Processor Type (required both for Linux & Windows OS): Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz

Operating System (required both for Linux & Windows OS): Ubuntu 16.04.3 LTS

In addition for Linux OS, please let us know the o/p of uname -r cmd on your system: Linux iot-demo 4.4.0 #2 SMP Tue Oct 17 11:42:45 CST 2017 x86_64 x86_64 x86_64 GNU/Linux   (Ubuntu 16.04 original kernel version4.10.0-28. I downgraded it as MSS release required.)

0 Kudos
1 Reply
Highlighted
76 Views

you may also want to try following command lines, on remote access.

$ export DISPLAY=:0.0

$ vainfo

0 Kudos