Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MyMother
Beginner
64 Views

Bitstream sequence

hi there,

OS: Ubuntu 12.04

       MediaSamples_Linux_6.0.16043175.175

       MediaServerStudioEssentials2015R6

Platform:  i5-4570S

I try to generate a video sequence as IP..P..., which contains only first I. I referred to https://software.intel.com/sites/default/files/mediasdk-man.pdf and try these variables like "GopRefDist = 1" and "GopPicSize = 0" but got failure because of the following 

[release] $ ffprobe -show_frames 1080p_enc.264 | grep -r "key_frame=1"
ffprobe version 2.1.1 Copyright (c) 2007-2013 the FFmpeg developers
  built on Aug  5 2014 05:02:01 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
  configuration: --enable-gpl --enable-nonfree --enable-pthreads --enable-x11grab --enable-version3 --enable-libx264 --enable-encoder=libx264 --enable-libvpx --disable-zlib --disable-debug
  libavutil      52. 48.101 / 52. 48.101
  libavcodec     55. 39.101 / 55. 39.101
  libavformat    55. 19.104 / 55. 19.104
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 90.100 /  3. 90.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Input #0, h264, from '1080p_enc.264':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: h264 (High), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 30 fps, 30 tbr, 1200k tbn, 60 tbc
key_frame=1
key_frame=1

Is there any way that I can achieve my goal ??

Thanks.

0 Kudos
2 Replies
MyMother
Beginner
64 Views

After change GopPicSize = -1, and I didn't find the second I frame.

The reason is according  to https://software.intel.com/sites/default/files/mediasdk-man.pdf , the definition

mfxU16 GopPicSize;    as I set GopPicSize=-1, actually it is 2^17-1 which equals the maximum of the variable.

Thanks

 

Surbhi_M_Intel
Employee
64 Views

Yes, that is a correct way to do it. great you got it. 
Closing this thread!

 

Reply