Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools from Intel. This includes Intel® oneAPI Video Processing Library and Intel® Media SDK.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

Error configure a Y416 HEVC encoder

cedronius__anders
New Contributor I
259 Views

 

System : Ubuntu 20.04

CPU:

model name : Intel(R) Core(TM) i5-10210U CPU @ 1.60GHz

libva:

libva info: VA-API version 1.11.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_11
libva info: va_openDriver() returns 0

MSDK:

Notification: The MSDK version Loaded is: v1.35

 

When trying to encode Y416 frames I get the error unsupported

cedronius__anders_2-1618232364798.png

Results in ->

cedronius__anders_1-1618230546472.png

Forcing the code/encoder to encode P010 frames generates no errors >

cedronius__anders_0-1618230380130.png

Results in ->

cedronius__anders_3-1618232860431.png

Why?

 

Thanks for helping.

/Anders.

 

0 Kudos
0 Replies
Reply