Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools from Intel. This includes Intel® oneAPI Video Processing Library and Intel® Media SDK.

Got a problem when runing samples

Wei_F_
Beginner
101 Views

After I installed the mediasdk 2015 r3, I ran samples(https://software.intel.com/en-us/intel-media-server-studio-support/code-samples)to test it.

But I got an error when running the sample_decode_drm.

I ran it like this

./sample_decode_drm h264 -i test_stream.264 -o output.yuv

then got

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
Decoding Sample Version 0.0.000.0000


Input video	AVC 
Output format	YUV420
Resolution	176x96
Crop X,Y,W,H	0,0,0,0
Frame rate	30.00
Memory type		system
MediaSDK impl		hw
MediaSDK version	1.13

Decoding started
Frame number:    0, fps: 0.000, fread_fps: 0.000, fwrite_fps: 0.000
Return on error: error code -1,	/home/fw/MediaSamples_Linux_5.0.1604371.71/samples/sample_decode/src/pipeline_decode.cpp	1263


Return on error: error code 1,	/home/fw/MediaSamples_Linux_5.0.1604371.71/samples/sample_decode/src/sample_decode.cpp	398

Is the command I used wrong or I didn't installed the mediasdk correctly?

Thanks

0 Kudos
3 Replies
Wei_F_
Beginner
101 Views

By the way

the OS I used is Centos 7 kernel 3.10.0-123.13.2.el7.x86_64

Cpu is Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz

Mother Board is H81M-VG4


 

Wei_F_
Beginner
101 Views

I have just solved the problem.

I removed the kernel 3.10.0-123.13.2.el7.x86_64, 3.10.0-123.13.1.el7.x86_64 and install the MSSr3 on 3.10.0-123.9.3.el7.x86_64.

Now the samples works well.

Sravanthi_K_Intel
101 Views

Hi Wei - Glad you found the issue. Good luck!

Reply