Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Helmuth_Schmitz
Beginner
104 Views

Hardware and Software library not found when testing with Media Checker

Hi Guys.
We made a application that is pretty much the same as sample_decode.exe
application that came with Intel Media SDK sample applications.
Everything was running fine, until we did a update for Intel MEdia SDK
, Intel Media Checker and the lastes drivers for Intel HD Graphics.
Now, when we try use Intel Media Checker for test it, we can see
the following information:
Monitoring:
Hardware library: None
Software Library: None

Our pc configuration used for tests is Intel I5(64bits), Intel
HD Graphics for video and Windows7.

Our application runs fine doing its job, but for monitoringprocess,
INtelMEdiaChecker is failing.Hope somebody can helpus to solve this issue.
Regards,
Helmuth Schmitz
0 Kudos
10 Replies
Anthony_P_Intel
Employee
104 Views

Hi Helmuth,

Does the sample_decode.exe provided in the Intel Media SDK still function (for both -sw and -hw)?

Is this only an issue with the Media Checker tool?

-Tony
Helmuth_Schmitz
Beginner
104 Views

Hi Tony, how are you?
Thanks for reply.
Weve tried use Intel Media checker for monitoring sample_decode.exe with these options:
sample_decode -hw mpeg2 -i d:\piano.vob -o d:\test.output
In fact, we put thiz call inside a file called "do_test.bat", and we use this .BAT file
inside the Media Checker.
Do you think this can be the problem?
Or maybe something else?
Thanks for helping us Tony.
Have a nice day,
Helmuth
Helmuth_Schmitz
Beginner
104 Views

somebody... any ideia?
Nina_K_Intel
Employee
104 Views

Hi Helmuth,

Very sorry for the delay. The engineer who had taken up your issue for investigation was on US public holidays. He should be back to work today, I will ask him to update the status here ASAP.

Regards,
Nina
IDZ_A_Intel
Employee
104 Views

Hi Helmuth,

again, sorry for the delay.

Could you please provide some additonal info regarding the version of Media SDK, Media Checker and Intel driver you are using. Have you made any other hardware configuration changes to your machine, such as enabling or adding discrete graphics card?

Some things you could try also:

- Try running sample_decode.exe to decode a stream without using a batch script or Media Checker. Look at the information regarding the decode operation that gets printed right after starting decode. "MediaSDK impl" should tell you if it is running in HW or SW. What do you get?
- Try uninstalling Media Checker then run the workload again. Media Checker may be interfering with Media SDK


Regards,
Petter
Helmuth_Schmitz
Beginner
104 Views

Hi Petter,
Thanks for reply.
I will try it, and soon as possible, i will inform you the results.
Thanks again for helping us.

Regards,
Helmuth
Helmuth_Schmitz
Beginner
104 Views

Hi,
i made some test, without the IntelMediaChecker, just executing that app based on sample_decode.exe
The results showed on console are:
Input video MPEG2
Output format YUV420
Resolution 720x576
Crop 0,0,720,576
Frame rate 25.00
Memory type System
MediaSDK impl hw
MediaSDK version 1.0
This was the console output.
In fact, even when we execute this app inside MediaChecker, the same results are displayed in
the console window, but, the MEdiaChecker window, keeping says that no Hardware and Software library found.
The version of SDK we are using is 2.0.12.2471(x64)
and the version of Media Checker is 2.0.1.18
Hope this information can help find the problem
Helmuth_Schmitz
Beginner
104 Views

More details about what we are using for the tests:
Windows7-Professional(Portuguese)
Intel I5
Intel HD Graphics(driver version: 8.15.10.2361 - Date: 04/10/2011)
Helmuth_Schmitz
Beginner
104 Views

more addition info about the core:
Intel GMA HD(Core I5-661)
IDZ_A_Intel
Employee
104 Views

Hi Helmuth,

from the information you provided (thanks!) it certainly looks like this is a Media Checker issue.

Did you try to uninstall then reinstall Media Checker?

If that does not work I suggest you contact the Software Partner Program support that is responsible for the Media Checker product and please report your issue there for them to debug.
http://www.intel.com/partner/support

Regards,
Petter
Reply