Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

Intel Core i7-7700K GPU Drivers Problem with CentOS 7


Hello All,

I am using CentOS 7.2.1511 (Gold Edition) for Intel Media SDK 2017 R2 to use the Intel QuickSync Technology for trans-coding video files,

I have install the Intel Media SDK with no problem and followed the steps in this documentation:

But when running the Intel System Analyzer for Linux

I got this error :


# ./ -v


Hardware readiness checks:


[ OK ] Processor name: Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz

[ INFO ] Intel Processor

[ INFO ] Processor brand: Core


OS readiness checks:


[ INFO ] GPU PCI id : 5912

[ INFO ] GPU description: unknown

[ ERROR ] No compatible GPU available. Check BIOS settings?



I have tried to check the lspci:

# lspci -nn -s 0:02.0

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:5912] (rev 04)


Also i doubt the problem was from the BIOS, I have checked the BIOS configuration and it was already enabled "iGFX" under peripherals menu.

Tried to install Windows 10 to be sure, It's worked fine without any problem,

But i still need to use the CentOS.


Here are some info about my hardware:

Motherboard Model: GIGABYTE GA-Z270M-D3H (rev. 1.0)

BIOS Version: F5

CentOS Linux release 7.2.1511 (Core)


0 Kudos
1 Reply


The reason for the error - is that Kaby Lake is not supported currently with MSDK. 

There is a sticky forum post clarifying Media SDK support for Kabylake: