Community
cancel
Showing results for 
Search instead for 
Did you mean: 
68 Views

Issue with IMSDK Hardware accelerated video decoder for VC1 files

Hi,

I am trying to run the sample application came along the mediasdk-tutorials-0.0.3. I have configured the decoder in MFX_CODEC_VC1 mode.

When i am giving VC1 input to it I am getting the following error:

./simple_decode -hw infile.vc1 out.yuv


libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0

 More input data expected. src/simple_decode.cpp 102

 

Looks like the issue is coming from header decode itself.

I have extracted this VC1 file from a WMV file. [I have used VLC player for extraction of elementary stream].

Am I missing some configuration or is that the way I am extracting input file itself has some issue? What is the expected format for input file?

 

--Regards

Thushara.

0 Kudos
13 Replies
Anna_B_Intel
Employee
68 Views

Hi Thushara,

Try to use sample_decode from Media Server Studio samples to decode VC1 streams. You can download samples package here: https://software.intel.com/en-us/intel-media-server-studio-support/code-samples or from the github: https://github.com/media-SDK/samples

Best wishes,

Anna

 

68 Views

Hi Anna,

Thanks for you prompt response.

I have downloaded MediaSamples_Linux_2016 from the link you have given.

But I am getting some build errors like below:

sysmem_allocator.cpp:220:10: error: âMFX_FOURCC_UYVYâ was not declared in this scope

pipeline_decode.cpp:951:25: error: MFX_MEMTYPE_EXPORT_FRAMEâ was not declared in this scope.

The corresponding header file doesn't have these definitions.

Is there any version mismatch.

My vainfo gives the following ouput:

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.1)
vainfo: Driver version: 16.4.2.1.39163-ubit
vainfo: Supported profile and entrypoints
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileNone                   : <unknown entrypoint>
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264Baseline           : VAEntrypointEncSlice
      VAProfileH264Baseline           : <unknown entrypoint>
      VAProfileH264Baseline           : <unknown entrypoint>
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : <unknown entrypoint>
      VAProfileH264Main               : <unknown entrypoint>
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : <unknown entrypoint>
      VAProfileH264High               : <unknown entrypoint>
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: <unknown entrypoint>
      VAProfileH264ConstrainedBaseline: <unknown entrypoint>
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : <unknown entrypoint>

 

 

 

Anna_B_Intel
Employee
68 Views

Hi Thushara,

What system/cpu do you use?

Best wishes,

Anna

68 Views

Hi Anna,

The cpu/system I am using is:

Intel NUC machine

CPU spec:

Intel(R) Core(TM) i5-4250U CPU @ 1.30GHz.

Running on Ubuntu 3.13.0-24-generic.

 

Regards

Thushara.

 

Anna_B_Intel
Employee
68 Views

It seems like you're using old version of Media Server Studio. Is it Media Server Studio 2016?

Best wishes,

Anna

68 Views

Hi Anna,

Yes my version is MediaServerStudioEssentials2015R6 .

I will update to 2016 and check again.

Thanks for your support

Regards

Thushara

68 Views

Hi Anna,

I have got the latest IMSDK 2016 on my Intel Apollo Lake machine running on Yocto genevi baseline linux.

In that , when I am trying to decode  VC1 file using the sample application provided , I am getting the following error:

 

./sample_decode vc1 -sw -i big_buck_bunny_720p_VC1_WMA3_25fps_4200K_short.WMV -o out.yuv

 

pretending that aspect ratio is 1:1
Decoding Sample Version 0.0.000.0000


Input video     VC1
Output format   NV12
Input:
Resolution    1280x720
Crop X,Y,W,H  0,0,1280,720
Output:
Resolution    1280x720
Frame rate      26.00
Memory type             system
MediaSDK impl           sw
MediaSDK version        1.17

Decoding started
Frame number:    0, fps: 0.000, fread_fps: 0.000, fwrite_fps: 0.000
Return on error: error code -16,        /opt/intel/mediasdk/samples/sample_decode/src/pipeline_decode.cpp       1774


Return on error: error code 1,  /opt/intel/mediasdk/samples/sample_decode/src/sample_decode.cpp 660

 

The header decoding is through, but the frame decoding is giving me MFX_ERR_UNDEFINED_BEHAVIOR.

 

Regards

Thushara Jayakumar.

 

 

Anna_B_Intel
Employee
68 Views

Hi Thushara,

Try to use input video files with .vc1 extension instead of .WMV. 

Best wishes,

Anna

68 Views

Hi Anna,

The input I gave contains only video file which is extracted using ffmpeg. I also have tried extracting raw video using VLC , but the behavior is same.

Regards

Thushara

Anna_B_Intel
Employee
68 Views

sample_decode works fine with raw video input. Could you please share with me your input file?Are you sure that it isn't corrupted?

Best wishes,

Anna

68 Views

Hi Anna,

I am attaching the original WMV file and the extracted raw video(using ffmpeg)  here. I am able to decode the extracted file using ffmpeg.

Regards

Thushara

Anna_B_Intel
Employee
68 Views

Thanks Thushara,

I reproduced the issue. It seems like a bug. I'll keep you in touch about it.

Best wishes,

Anna

68 Views

Hi Anna,

Thanks for your response. Looking forward for  the fix.

 

Regards

Thushara Jayakumar

Reply