Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Ankit_G_
Beginner
148 Views

MFX_ERR_UNSUPPORTED(-3), Init, m_pmfxDEC->Init failed

Hi all,

I am using MediaServerStudioEssentials2017R3 on CentOS Linux release 7.3.1611 (Core).

I am able to run sample decode applicaition with -sw but getting error with -hw option.

Any help will be appreciated. Please check below snapshot for logs.


[user@localhost Downloads]$ python sys_analyzer_linux.py -v
--------------------------
Hardware readiness checks:
--------------------------
 [ OK ] Processor name: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
 [ INFO ] Intel Processor
 [ INFO ] Processor brand: Core
 [ INFO ] Processor arch: Skylake
--------------------------
OS readiness checks:
--------------------------
 [ INFO ] GPU PCI id     : 1912
 [ INFO ] GPU description: SKL DT GT2
 [ OK ] GPU visible to OS
 [ INFO ] no nomodeset in GRUB cmdline (good)
 [ INFO ] Linux distro   : CentOS Linux 7.3.1611
 [ INFO ] Linux kernel   : 3.10.0-514.26.2.el7.x86_64
 [ INFO ] glibc version  : 2.17
 [ INFO ] Linux distro suitable for Generic install
 [ INFO ] gcc version    : 4.8.5-11) (>=4.8.2 suggested)
--------------------------
Media Server Studio Install:
--------------------------
 [ OK ] user in video group
 [ OK ] libva.so.1 found
 [ INFO ] Intel iHD used by libva
 [ OK ] vainfo reports valid codec entry points
 [ INFO ] i915 driver in use by Intel video adapter
 [ OK ] /dev/dri/renderD128 connects to Intel i915
--------------------------
Component Smoke Tests:
--------------------------
 [ OK ] Media SDK HW API level:1.23
 [ OK ] Media SDK SW API level:1.23
 [ OK ] OpenCL check:platform:Intel(R) OpenCL GPU OK CPU OK

 

// Sample test with sw

[ankit@localhost x64]$ ./sample_decode h264 -i out.264 -o /home/ankit/out1.yuv -sw
Decoding Sample Version 8.0.24.698


Input video    AVC
Output format    NV12
Input:
  Resolution    3840x2160
  Crop X,Y,W,H    0,0,0,0
Output:
  Resolution    3840x2160
Frame rate    30.00
Memory type        system
MediaSDK impl        sw
MediaSDK version    1.23

Decoding started
Frame number:  751, fps: 13.769, fread_fps: 0.000, fwrite_fps: 14.0504
Decoding finished

 

// Sample test with hw

[user@localhost x64]$ ./sample_decode h264 -i out.264 -o /home/user/out1.yuv -hw
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), Init, m_pmfxDEC->Init failed at /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK1/git/mdp_msdk-lib/samples/sample_decode/src/pipeline_decode.cpp:446

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), main, Pipeline.Init failed at /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK1/git/mdp_msdk-lib/samples/sample_decode/src/sample_decode.cpp:719

0 Kudos
3 Replies
Anna_B_Intel
Employee
148 Views

Hi Ankit, 

Do other codecs like mpeg2 or HEVC work well in hw mode on your machine?

Best wishes, 

Anna

Ankit_G_
Beginner
148 Views

Hi,

JPEG also doesn't work with -hw.

And h265 doesn't work with sw as well.

Thanks,

Ankit

Anna_B_Intel
Employee
148 Views

Hi Ankit, 

How did you install Media Server Studio? It seems like you have wrong kernel. You need to install 3.10.0-514.el7.x86_64 kernel. 

That's expected that h265 doesn't work in -sw mode, because sw implementation is available only in Intel(R) Media Server Studio Professional Edition (you have Essentials edition).

Best wishes,

Anna 

Reply