Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools from Intel. This includes Intel® oneAPI Video Processing Library and Intel® Media SDK.

MFX_ERR_UNSUPPORTED(-3) on running sample decode app

raghaw_s_
Beginner
217 Views

Hi ,

 When i run the sample decode example i get the below error:

./sample_decode h264 -i ../content/test_stream.264 -o output.yuv -hw

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), Init, m_pmfxDEC->Init failed at /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK3/git/mdp_msdk-samples/samples/sample_decode/src/pipeline_decode.cpp:436

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), main, Pipeline.Init failed at /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK3/git/mdp_msdk-samples/samples/sample_decode/src/sample_decode.cpp:681

 

Quick help will be highly appreciated.

Following are the system details:

--------------------------
Hardware readiness checks:
--------------------------
 [ OK ] Processor name: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz
 [ INFO ] Intel Processor
 [ INFO ] Processor brand: Core
 [ INFO ] Processor arch: Skylake
--------------------------
OS readiness checks:
--------------------------
 [ INFO ] GPU PCI id     : 1912
 [ INFO ] GPU description: SKL DT GT2
 [ OK ] GPU visible to OS
 [ INFO ] no nomodeset in GRUB cmdline (good)
 [ INFO ] Linux distro   : Ubuntu 16.04
 [ INFO ] Linux kernel   : 4.4.47
 [ INFO ] glibc version  : 2.23
 [ INFO ] gcc version    : 20160609 (>=4.8.2 suggested)
 [ INFO ] /dev/dri/card0 : YES
 [ INFO ] /dev/dri/renderD128 : YES
--------------------------
Intel(R) Media Server Studio Install:
--------------------------
 [ OK ] user in video group
 [ OK ] libva.so.1 found
 [ INFO ] Intel iHD used by libva
 [ OK ] vainfo reports valid codec entry points
 [ INFO ] i915 driver in use by Intel video adapter
 [ OK ] /dev/dri/renderD128 connects to Intel i915

--------------------------
Media SDK Plugins available:
(for more info see /opt/intel/mediasdk/plugins/plugins.cfg)
--------------------------
    HEVC Decoder     = 15dd936825ad475ea34e35f3f54217a6
    HEVC Encoder     = e5400a06c74d41f5b12d430bbaa23d0b
    HEVC Encoder     = 2fca99749fdb49aeb121a5b63ef568f7
--------------------------
Component Smoke Tests:
--------------------------
 [ OK ] Media SDK HW API level:1.19
 [ OK ] Media SDK SW API level:1.19
 [ OK ] OpenCL check:platform:Intel(R) OpenCL GPU OK CPU OK

 

 

0 Kudos
1 Reply
Mark_L_Intel1
Moderator
217 Views

Hi raghaw,

Did you applied the kernel patches and rebuild the kernel?

According to this article for the generic installation process, the kernel must be rebuilt. 

The other issue is, Ubuntu installation is never fully supported and validated, according to the article, we only testes in SkyLake + Kernel 4.4 + MSS2017 or Broadwell + Kernel 3.14.5 + MSS 2016 combinations, but even these conditions are satisfied, it still could be failed.

I suggest to try the CentOS 7.2.1511 distribution with the gold installation for a reliable result.

Mark

Reply