Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
33 Views

MFX_WRN_PARTIAL_ACCELERATION when initializing encoder

I am using the Intel Media SDK 2014 R2 to use the hardware H264 encoder to encode video.

I have created a sample program to initialize the video session and initialize an encoder using the hardware encoder. I am using Microsoft Visual Studio 2013 for this.

If I use the MFX_IMPL_HARDWARE_ANY implementation, the session is initialized and if I query it is says it's using the hardware implementation. But when I try to initialize the encoder, I get the MFX_WRN_PARTIAL_ACCELERATION warning, and the encoding process isn't accelerated at all (the GPU usage is at 0%, and the CPU usaget is high when encoding).

If I use the MFX_IMPL_HARDWARE or MFX_IMPL_HARDWARE2 implementations, the session fails to initialize with error MFX_ERR_NOT_FOUND.

But if I use the MFX_IMPL_HARDWARE3 implementation, the session and the encoder initializes successfully and I don't get the MFX_WRN_PARTIAL_ACCELERATION warning. Also, the encoding process really uses the hardware encoder because the CPU usage is low and the GPU usage is high. This is what I want.

I ran the mediasdk_system_analyzer_32.exe file, and it says that hardware decoding and encoding is not supported on my system, even though I can use it if I use the MFX_IMPL_HARDWARE3 implementation.

I have an NVIDIA GTX 650 graphics adapter and also an Intel HD 4000 adapter. The integrated graphics is enabled in my BIOS. I have two monitors connected to the NVIDIA card and no monitor connected to the Intel card, but I have connected a fake monitor on the Intel card and I have extended my desktop to it. This is done to enable the Intel card, I cannot use the hardware acceleration if I don't do this.

I am attaching the output of the mediasdk_system_analyzer_32.exe tool to this post, and I am also attaching my small test program so you can check it out and see if I'm making a mistake somewhere.

0 Kudos
4 Replies
Highlighted
Beginner
33 Views

I also tried using the latest Intel graphics driver, version 15.33.22.3621 (10.18.10.3621), and I get the same results.

How can I fix this?

0 Kudos
Highlighted
Beginner
33 Views

Hi,

this is an old thread, but i have stumbled upon the same issue. i am using NVidia Quadro 4000 and Intel HD 4600. i am getting the same warning and the encoding isn't fast. anyone has any idea?

 

0 Kudos
Highlighted
33 Views

Hi Ovidiu - Can you please let us know the following:

- On your system, what version of DirectX do you have? DirectX 9 or 11? Can you run the "dxdiag.exe" and paste the output please?

-  If you take our validated sample applications from here, https://software.intel.com/en-us/intel-media-server-studio-support/code-samples , and ran the sample_decode (for example) are you able to reproduce the issue? Alternately, you can take our simpler examples (from here - https://software.intel.com/en-us/intel-media-server-studio-support/training) and see if you can reproduce the issue.

- Note: MSDK 2014 R2 is very old and we do not extend our support to such old versions. Can you please update to latest MSS version (you can download the MSDK from here https://software.intel.com/en-us/intel-media-server-studio/try-buy - the community edition is free and has the MSDK you are looking for) as well? 

Venkatesh - Can you also provide the information I am requesting from Ovidiu, and also give your full system/MSS version details?

0 Kudos
Highlighted
Beginner
33 Views

Any updates? I'm seeing something similar using MediaSDK 7.0.0.311.

2 displays are using the NVIDIA Quadro M2000M and 1 display is using Intel(R) HD Graphics 530.

I'm finding that MFX_IMPL_HARDWARE_ANY, MFX_IMPL_HARDWARE, MFX_IMPL_HARDWARE2, MFX_IMPL_HARDWARE3, MFX_IMPL_HARDWARE4 all return unsupported.

 

 

 

 

0 Kudos