Community
cancel
Showing results for 
Search instead for 
Did you mean: 
l_k_1
Beginner
177 Views

MFXQueryVersion with driver Version:15.33.22.3621 problem?

Hi,

          I use Version:15.33.22.3621 for my i7-4770 and i7-3370 both get  version.Minor == 10  ?

       

        mfxVersion HWversion = {0,1};
        mfxSession HWsession;
        mfxStatus sts;
        sts = MFXInit(MFX_IMPL_HARDWARE_ANY, &HWversion, &HWsession);  
        if (MFX_ERR_NONE == sts)
        {
            MFXQueryVersion(HWsession,&version);
            #ifdef _DEBUG
            printf("\nIntel Media SDK. HW API Level: %d.%d",version.Major, version.Minor);
            #endif
        }

       And I get error for use this version.Minor == 10 to init session ?      

Please Help!  

Regards,

LK

0 Kudos
2 Replies
Anthony_P_Intel
Employee
177 Views

The driver you are using does not actually support API 1.10 (which is not a published API yet), and the query is incorrect.  The error on initialization is correct. Please do not use API value that is higher than the SDK you are using.

Thank you for pointing out this bug.

l_k_1
Beginner
177 Views

Thanks, Tony

       Get it.

Regards,

LK

Reply