Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Naresh_B_
Beginner
136 Views

MFXVideoCORE_SyncOperation always failing with MFX_ERR_DEVICE_FAILED(-17) in win10

Hi,

I am recently facing issue with h264 encoding with intel media sdk in win10 which was working properly other than win10.

I ran simple_encode.exe with 

  h264 -i sample.yuv -o OutputEncodedFile -w 1280 -h 720 -hw which was not working(MFXVideoCORE_SyncOperation giving error -17 ) where as if I ran same with h264 -i sample.yuv -o OutputEncodedFile -w 1280 -h 720 -hw -d3d working without any issue.

Can somebody help me to trace the problem why encoder is giving error -17 with MFX_IOPATTERN_IN_SYSTEM_MEMORY

My machine config:

The following versions of Media SDK API are supported by platform/driver:
 
        Version Target  Supported       Dec     Enc
        1.0     HW      Yes             X       X
        1.0     SW      Yes             X       X
        1.1     HW      Yes             X       X
        1.1     SW      Yes             X       X
        1.3     HW      Yes             X       X
        1.3     SW      Yes             X       X
        1.4     HW      Yes             X       X
        1.4     SW      Yes             X       X
        1.5     HW      Yes             X       X
        1.5     SW      Yes             X       X
        1.6     HW      Yes             X       X
        1.6     SW      Yes             X       X
        1.7     HW      Yes             X       X
        1.7     SW      Yes             X       X
        1.8     HW      Yes             X       X
        1.8     SW      Yes             X       X
 
Graphics Devices:
        Name                                         Version             State
        Intel(R) HD Graphics 530                     10.18.15.4279       Active
 
System info:
        CPU:    Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
        OS:     Microsoft Windows 10 Pro
        Arch:   64-bit
 
Installed Media SDK packages (be patient...processing takes some time):
        Intel« Media SDK 2016
        Intel« Media SDK 2016 R2
 
Installed Media SDK DirectShow filters:
 
Installed Intel Media Foundation Transforms:
  Intel« Hardware M-JPEG Decoder MFT : {00C69F81-0524-48C0-A353-4DD9D54F9A6E}
  Intel« Hardware VP9 Sync Decoder MFT : {07AB4BD2-1979-4FCD-A697-DF9AD15B34FE}
  Intel« Hardware VP9 Decoder MFT : {0C69E30B-A112-4A86-B496-35120CD745D5}
  Intel« Hardware VP8 Sync Decoder MFT : {451E3CB7-2622-4BA5-8E1D-44B3C41D0924}
  Intel« Hardware VP8 Decoder MFT : {6D856398-834E-4A89-8EE5-071BB3F58BE4}
  Intel« Quick Sync Video H.264 Encoder MFT : {4BE8D3C0-0515-4A37-AD55-E4BAE19AF471}
  Intel« Hardware H265 Encoder MFT : {BC10864D-2B34-408F-912A-102B1B867B6C}
0 Kudos
2 Replies
Anna_B_Intel
Employee
136 Views

Hi Naresh,

It seems like you have old driver. Update it to the latest version and try to run encoding one more time.

Best wishes,

Anna

Naresh_B_
Beginner
136 Views

Hi Anna,

I updated my media sdk to 1.19 from 1.16 but still 1.16 sdk loading when I MFXInit();

Do you have any Idea about this problem?.

Coming to my Issue,is it problem with SDK or Hardware?

Reply