Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mohammad_T_1
Beginner
59 Views

MFXVideoDECODE_Query(m_session, in, out) returns -1.

Jump to solution

Hi 

I am facing error -1 which MFXVideoDecode_Qurery() returns . I am running exe which i have created to capture screen i.e., screen_capture.exe with it's plugin 22d62c07e672408fbb4cc20ed7a053e4, which is running very well on my system but on my second sytem that screen_capture and it's plugins return error -1 from MFXVideoDecode_Qurery() function. My system configuration of second system  is:

Intel Media SDK System Analyzer (32 bit)


The following versions of Media SDK API are supported by platform/driver:

        Version Target  Supported       Dec     Enc
        1.0     HW      Yes             X       X
        1.0     SW      No
        1.1     HW      Yes             X       X
        1.1     SW      No
        1.3     HW      Yes             X       X
        1.3     SW      No
        1.4     HW      Yes             X       X
        1.4     SW      No
        1.5     HW      Yes             X       X
        1.5     SW      No
        1.6     HW      Yes             X       X
        1.6     SW      No
        1.7     HW      Yes             X       X
        1.7     SW      No
        1.8     HW      Yes             X       X
        1.8     SW      No

Graphics Devices:
        Name                                         Version             State
        Intel(R) HD Graphics                         10.18.10.3958       Active

System info:
        CPU:    Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz
        OS:     Microsoft Windows 8.1 Pro
        Arch:   64-bit

Installed Media SDK packages (be patient...processing takes some time):

Installed Media SDK DirectShow filters:

Installed Intel Media Foundation Transforms:
  Intel« Hardware M-JPEG Decoder MFT : {00C69F81-0524-48C0-A353-4DD9D54F9A6E}
  Intel« Hardware VP9 Sync Decoder MFT : {07AB4BD2-1979-4FCD-A697-DF9AD15B34FE}
  Intel« Hardware VP9 Decoder MFT : {0C69E30B-A112-4A86-B496-35120CD745D5}
  Intel« Hardware VP8 Sync Decoder MFT : {451E3CB7-2622-4BA5-8E1D-44B3C41D0924}
  Intel« Hardware VP8 Decoder MFT : {6D856398-834E-4A89-8EE5-071BB3F58BE4}
  Intel« Quick Sync Video H.264 Encoder MFT : {4BE8D3C0-0515-4A37-AD55-E4BAE19AF
471}

This second is having msdk library installed.

Help me to get the solution. 

Thank you

 

0 Kudos
1 Solution
Surbhi_M_Intel
Employee
59 Views

Hi Mohammad, 

From your description - You have developed a screen capture application and in that application decode query return error -1 on your 2nd system, which works perfectly for your system1.

Few things we can do to debug this issue- 
1. Does your both systems have same configuration? same driver version? and Media SDK installed?
2. I see from the details of machine2, which you have provided above had old driver version, please update to latest and check. 
Driver for your system can be found here - https://downloadcenter.intel.com, the latest version is 4276. 
3. If the issue still persist, please compare the tracer logs of both system. 
4. Can you try the screen capture sample which is part of sample package on machine 2 and provide your results. 

Thanks,
Surbhi

View solution in original post

3 Replies
Surbhi_M_Intel
Employee
60 Views

Hi Mohammad, 

From your description - You have developed a screen capture application and in that application decode query return error -1 on your 2nd system, which works perfectly for your system1.

Few things we can do to debug this issue- 
1. Does your both systems have same configuration? same driver version? and Media SDK installed?
2. I see from the details of machine2, which you have provided above had old driver version, please update to latest and check. 
Driver for your system can be found here - https://downloadcenter.intel.com, the latest version is 4276. 
3. If the issue still persist, please compare the tracer logs of both system. 
4. Can you try the screen capture sample which is part of sample package on machine 2 and provide your results. 

Thanks,
Surbhi

View solution in original post

Mohammad_T_1
Beginner
59 Views

Hi Surbhi

Thanks for you reply. The error is resolved by updating the driver.

Thank  you

 

Surbhi_M_Intel
Employee
59 Views

Great! I am closing this issue, please start a new thread on Media forum if you come across any new issues with Media SDK Client. 

Thanks,
Surbhi

Reply