Community
cancel
Showing results for 
Search instead for 
Did you mean: 
duncanchou
New Contributor I
863 Views

MSDK resize the render but display is full size.

Jump to solution

Hello Sir,

If we want to display the video to 640x360 from 1920x1080, how to do setting the parameter of MSDK?

We do below command, but the display is full size not 640x360 

root@intel-corei7-64:/mnt/nfsshare/MediaSDK-intel-mediasdk-20.2.1/build# __bin/release/sample_decode h264 -hw -gpucopy::on -f 28 -window 0 0 640 360 -rgb4 -vaapi -i /mnt/nfsshare/stream_test.h264 -rdrm
Init, /mnt/nfsshare/stream_test.h264
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
drmrender: trying connection: HDMIA
drmrender: selected crtc already attached to connector
drmrender: succeeded...
drmrender: connected via HDMIA to 1920x1080@60 capable display
Decoding Sample Version 20.2.0


Input video AVC
Output format RGB4 (using vpp)
Input:
Resolution 1920x1088
Crop X,Y,W,H 0,0,1920,1080
Output:
Resolution 640x360
Frame rate 30.00
Memory type vaapi
MediaSDK impl hw
MediaSDK version 1.32

Decoding started
drmrender: warning: rendering via OVERLAY plane0, fwrite_fps: 0.000
Frame number: 131, fps: 27.328, fread_fps: 4352.015, fwrite_fps: 28.101

Thanks 

Michael Wu

0 Kudos
1 Solution
duncanchou
New Contributor I
714 Views

Hello Mark,

We setup the window attributes to "override_redirect = true" ,  the  "get wrong render window position" issue can be fixed.

Thanks 

Michael Wu 

View solution in original post

10 Replies
Luis_at_Intel
Moderator
829 Views

Hi @duncanchou ,

 

Thanks for reaching out. Could you please share details about your environment? 

  • Library version
  • OS info and version
  • Compiler version
  • GCC or Visual Studio version if applicable.

DRM rendering mode (-rdrm) should work without any graphical server (i.e. X Server or Wayland) running. Not sure if your current setup lacks a graphical server, if it does have a graphical server please try using -r (or -rwld for Wayland) instead of -rdrm and see if it makes any difference. Let me know the results. 

sample_decode h264 -hw -gpucopy::on -f 28 -window 0 0 640 360 -rgb4 -vaapi -i /mnt/nfsshare/stream_test.h264 -r

 

Best Regards,

Luis

duncanchou
New Contributor I
821 Views

Hello Luis,

Our environment is following,

  • Library version  ==> libva 2.7.0
  • OS info and version ==>  Linux 4.19.130-intel-pk-standard (Our platform is Atom E3950)
  • Compiler version ===> gcc version 8.3.0 (GCC) 
  • GCC or Visual Studio version if applicable.  gcc version 8.3.0 (GCC) 

The attached is a environment .txt .

Thanks 

Michael Wu

 

Luis_at_Intel
Moderator
807 Views

Hi @duncanchou ,

Thank you for the information, could you provide the output of the following command:

echo $XDG_SESSION_TYPE

Instead of using parameter -window 0 0 640 360, please use -w and -h parameters with their respective values and see if that makes any difference. 

 

sample_decode h264 -hw -gpucopy::on -f 28 -rgb4 -vaapi -i /mnt/nfsshare/stream_test.h264 -rdrm -w 640 -h 360

 

 

Best Regards,

Luis 

duncanchou
New Contributor I
791 Views

Hello Luis,

echo $XDG_SESSION_TYPE


====> Response is "tty"

sample_decode h264 -hw -gpucopy::on -f 28 -rgb4 -vaapi -i /mnt/nfsshare/stream_test.h264 -rdrm -w 640 -h 360

====> Without difference.

 

Thanks 

Michael Wu

Mark_L_Intel1
Moderator
759 Views

Hi Michael,


I tried to reproduce your issue but I can't.


I can't use -rdrm in my environment since it doesn't support it, does this matter?


Your information only tells me kernel version, latest Media SDK and Apollo Lake(E3950) for hardware, but no OS version. But this should be OK to the problem.


Our sample code is only for demo and performance checking purpose, rendering is not part of Media SDK so it should not block you from developing your application.


This feature should work if you just install Media SDK 20.2.1 in a new Ubuntu 18.4 with "-r" for rendering option, this feature should work. So I would say this is more like an environment issue but let me know if I missed any information here.


Mark


duncanchou
New Contributor I
738 Views

Hello Mark,

We installed the Ubuntu 18.4 + Media SDK 20.2.1 with "-r" for rendering option, 

We can resize the  render,

Thank you for your help. 

 

Michael Wu

duncanchou
New Contributor I
726 Views

Hello Mark,

One more question, if we do below cmd,  we always get wrong  render window position,  we mention the position is 1280 720, but it is not, may be we miss some steps.   

The attached  is a tested picture test_x11_20201019.png 

__bin/release/sample_decode h264 -hw -gpucopy::on -f 28 -rgb4 -vaapi -window 1280 720 1280 720 -i /mnt/nfsshare/test.h264 -r

 

Thanks

Michael Wu

duncanchou
New Contributor I
715 Views

Hello Mark,

We setup the window attributes to "override_redirect = true" ,  the  "get wrong render window position" issue can be fixed.

Thanks 

Michael Wu 

View solution in original post

Mark_L_Intel1
Moderator
687 Views

Thanks Michael,


It seems our argument has some issues with the windows positioning, the rendering function has always related to the OS environments. I am glad that you solved it.


Mark Liu


duncanchou
New Contributor I
673 Views

Hello Mark,

Thank you for your help and kindly support. 

Michael 

Reply