Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools from Intel. This includes Intel® oneAPI Video Processing Library and Intel® Media SDK.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Media Accelerator problem decode - filter - encode

User4221
Beginner
534 Views

Hi everyone

asking for help with the Media Accelerator

i am trying to run an image thru the accelerator how ever the image is loosing color in the output

with out using the filters, can any one please help me understand why?

thank you in advanced!

commands in order: 

sample_decode.exe jpeg -i 3.jpg -o out.yuv
sample_vpp.exe -sw 1706 -sh 1280 -scc nv12 -dw 1706 -dh 1280 -iopattern d3d_to_d3d -i out.yuv -o out_modifed.yuv
sample_encode.exe jpeg -i out_modifed.yuv -o outputfile.jpg -w 1706 -h 1280 -sw -q 100  

 

0 Kudos
1 Solution
Mark_L_Intel1
Moderator
431 Views

Hi Tal,

Sorry for the late response since I was busy on other project.

My colleagues and I did some research and we found only the final output file has the black/white problem you mentioned, so I checked the readme of sample_encode.exe:

In the optional argument, it says the default input format is YUV420, since the output of sample_vpp.exe is NV12, this is the issue. You should add "-nv12" in the middle of the command so it becomes

 

sample_encode.exe jpeg -i out_modifed.yuv -nv12 -o outputfile.jpg -w 1706 -h 1280 -sw -q 100

 

I have checked outputfile.jpg and it has the correct color.

Mark

 

View solution in original post

5 Replies
RaeesaM_Intel
Moderator
510 Views

Hi,


Thank you for reaching out to us.

We are trying to figure out your issue internally. We will get back to you on the updates.


Regards,

Raeesa



User4221
Beginner
507 Views
RaeesaM_Intel
Moderator
467 Views

Hi,


We were able to reproduce your issue from our end. We are forwarding this case to subject matter experts.


Thank you ,

Raeesa


Mark_L_Intel1
Moderator
432 Views

Hi Tal,

Sorry for the late response since I was busy on other project.

My colleagues and I did some research and we found only the final output file has the black/white problem you mentioned, so I checked the readme of sample_encode.exe:

In the optional argument, it says the default input format is YUV420, since the output of sample_vpp.exe is NV12, this is the issue. You should add "-nv12" in the middle of the command so it becomes

 

sample_encode.exe jpeg -i out_modifed.yuv -nv12 -o outputfile.jpg -w 1706 -h 1280 -sw -q 100

 

I have checked outputfile.jpg and it has the correct color.

Mark

 

View solution in original post

User4221
Beginner
400 Views
Reply