Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
14 Views

Problems with Trace routine and samples

Hi:

         I have multiple versions of samples and INDE installed on my Windows 7 x64 computer.  I'm using Visual Studio 2010 (though the Community Edition is also installed).  The samples  include Media SDK 2013 R2,  Intel Media samples 6.0.0.049 and 6.0.0.98947.  The INDE folder contains versions of Media SDK media_sdk_6.0.0.308 and _sdk_6.0.0.349.

   There are multiple problems related, I believe, due to these multitude of versions and how their installations set up..

    1,  The Media Sdk Tracer programs from media_sdk_6.0.0.308 and _sdk_6.0.0.349 do not do anything when attempting to trace, but the version from  Media SDK 2013 R2 works fine  (regardless of whether the samples I try to run are from Media SDK 2013 R2,  Intel Media samples 6.0.049 and 6.0.0.98947) .

    2,  When attempting to run the sample_full_transcode  from the Intel Media samples 6.0.0.98947

 the programs fails at sts = m_pENC->Init(&m_initVideoParam); in the transform_venc.cpp void Transform <MFXVideoENCODE>::InitEncode(SamplePtr& sample) routine with an sts = -12, even-though the mfxStatus sts = m_pENC->Query(&m_initVideoParam, &m_initVideoParam); returns no error.

  3, When attempting to compile the sample_full_transcode  from the Intel Media samples 6.0.0.049 it fails with "can't find libmfx_d.lib,  though that file exists in the INDE folder.  I could fix this, but it is indicative to me that some synchronization between the INDE versions and the samples is not correct since the Intel Media samples 6.0.0.98947 compiles fine.

   I'm running the sample with the simplest command line   "-i c:\aaamtest2ts.m2ts -o c:\fullt.m2ts".  If I use "-i c:\aaamtest2ts.m2ts -o c:\fullt.mp4" it also fails with an error  (though a different one).  The aaamtest2ts.m2ts is video only!!

   Any suggestions???

    Mags

 

0 Kudos
14 Replies
Highlighted
14 Views

Hi,

The current version of MediaSDk 2013 you are using is very old. We regularly update and fix bug with latest releases. May I suggest updating to latest version of the MediaSDK from here: https://software.intel.com/intel-inde. This will help in resolving issue 1 (media_sdk_6.0.0.308 and _sdk_6.0.0.349) and issue2(Intel Media samples 6.0.0.98947) as we can be start triage the issue using latest version of MediaSDK. Please verify and update to latest graphic drivers from here: https://downloadcenter.intel.com/.

In regard to "can't find libmfx_d.lib" from samples ver. 6.0.0.049, this is a know limitations with samples, please refer to samples release notes. Few suggestions, please build the samples in release mode or add this to linker in configuration properties. 

Also I would like to inform, with new INDE MSDK 2015 update please consider full transcode sample end of life, published as legacy samples but no longer supported. We do not encourage their use and they are still up just as a reference.

 

Thanks,

0 Kudos
Highlighted
Beginner
14 Views

Hi Harsh:

   I believe I do have the latest version of INDE;  i.e.  Update 2.  In fact if I try to re-load it, it gives only the option of remove or change, not repair which I would assume implies that the version installed is correct.  If I look for samples, the download suggest  6.0.0.049, which is presumably an earlier version than  6.0.0.98947.  Are there any newer versions of the SDK  (i.e. newer than Update 2), and newer versions of the samples than either 6.0.0.049 or 6.0.0.98947.  The link you provided for the samples points to 6.0.0.049 that I already have.

   The older versions of the SDK and samples I have so I don't break existing code;  nonetheless I'd assume that the newer samples and Update 2 should work together.

   In any case the fact that the older version of Tracer works (on the newer samples) and the newer versions of the Tracer does not is bizarre.

  As to the full transcode issue,  while I understand that you would not make improvements to it, IT SHOULD at least work as advertised otherwise one just wastes a lot of time trying to make a broken product work.  If one is to upgrade to a paid version of the SDK, there must be some confidence that at least the samples work correctly!!!

   Mags

 

0 Kudos
Highlighted
14 Views

Hi,

The current version of the latest samples is ver 6.0.0.049. The ver. 6.0.098947 is the older version of samples. Hence the samples ver. 6.0.0049 you have are  latest. From the latest version (6.0.0.049) of the samples, you can find full transcode sample as part of deprecated folder in samples folder.

All the the older versions of MediaSDK and samples (encode,decode,vpp etc) are supported with INDE update 2, with expection to the samples in deprecated folder. The latest version of MediaSDK supported is ver. 1.15.

Also in regard to tracer issue, can you send me snapshot of the issue. Does the tracer tool break? Can you please provide more description on the issue. I tried tracer tool available with latest MSDK package and could not reproduce the issue you are seeing. If can send me log from <mediasdk>/tools/analyzer will help understanding the system configuration.

There are lot of changes on support from mediasdk and graphic drivers. We appreciate your feedback and we are working on clearing the message with deprecated samples (ver 6.0.0.049), hence I mentioned in my previous comment with INDE update 2 and samples ver. 6.0.049 full transcode sample is part of legacy and there usage is not encouraged but still up just as reference. 

Thanks,

 

0 Kudos
Highlighted
14 Views

Hi, 

  I'm running the sample with the simplest command line   "-i c:\aaamtest2ts.m2ts -o c:\fullt.m2ts".  If I use "-i c:\aaamtest2ts.m2ts -o c:\fullt.mp4" it also fails with an error  (though a different one).  -> In regard to this error, we tried with one of our own samples and didnot see any issue . Can you please provide more description on the issue you are seeing? Also, for us to know complete system information can you send us a log from analyzer <mediaSDK>/tools/analyzer.

Latest version with INDE update 2 are -> media_sdk_6.0.0.349 (API 1.15), media samples ver 6.0.0.49. 

Also, in regard to full transcode sample there is a FFmpeg* depedency for splitters and muxers with ver. 2.0.2. Please verify if the correct version of the ffmpeg is installed and path depedency added to environment variable. Please refer to Media sample guide for download link and more information.

Thanks,

 

0 Kudos
Highlighted
Beginner
14 Views

Hi Harsh:

    Thanks for the reply.  Below is the analyzer output.  I was using version 6.0.0.98947 of the samples  (assuming that the higher number meant a newer version).  I will try using the 6.0.0.049 to do the full transcode.  I do have the correct version of the FFMPEG routines.

As for the Tracer issue, the  Tracer starts up;  when I select per-frame logging and press start, the Kbytes written remains at zero, and when I run my app it does not change.  If I run the older version of tracer that works,  upon pressing start 128 Kbytes are written and when I start my app that number grows as expected.

    Mags

 

Intel Media SDK System Analyzer (64 bit)

The following versions of Media SDK API are supported by platform/driver:

        Version Target  Supported       Dec     Enc

        1.0     HW      Yes             X       X

        1.0     SW      Yes             X       X

        1.1     HW      Yes             X       X

        1.1     SW      Yes             X       X

        1.3     HW      Yes             X       X

        1.3     SW      Yes             X       X

        1.4     HW      Yes             X       X

        1.4     SW      Yes             X       X

        1.5     HW      No

        1.5     SW      Yes             X       X

        1.6     HW      No

        1.6     SW      Yes             X       X

        1.7     HW      No

        1.7     SW      Yes             X       X

        1.8     HW      No

        1.8     SW      Yes             X       X

 

Graphics Devices:

        Name                                         Version             State

        NVIDIA NVS 4200M                             9.18.13.2762        08

        Intel(R) HD Graphics 3000                    9.17.10.3347        Active

 

System info:

        CPU:    Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz

        OS:     Microsoft Windows 7 Professional

        Arch:   64-bit

 

Installed Media SDK packages (be patient...processing takes some time):

        Intel« Media SDK Video Processing Sample 5.0.461.91752

        Intel Media SDK DirectShow* Sample 5.0.337.78585

        Intel Media SDK Video Decoding Sample 5.0.337.78585

        Intel« Media SDK Video Decoding Sample 5.0.461.91752

        Intel« Media SDK Video Transcoding Sample 5.0.461.91752

        Intel« INDE Media SDK for Windows 6.0.0.308

        Intel« INDE Media SDK for Windows 6.0.0.349

        Intel« Media SDK 2014 R2 for Clients (x64)

        Intel« Media SDK 2013 R2 (x64)

 

Installed Media SDK DirectShow filters:

  Intel« Media SDK MP3 Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_mpa_dec_ds.dll

 

  Intel« Media SDK JPEG Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\jpeg_dec_filter.dl

l

  Intel« Media SDK MPEG-2 Splitter :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_mp2_spl_ds.dll

 

  Intel« Media SDK H.264 Encoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_build\x64\Debug\h264_enc_f

ilter.dll

  Intel« Media SDK MVC Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\mvc_dec_filter.dll

 

  Intel« Media SDK AAC Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_aac_dec_ds.dll

 

  Intel« Media SDK MPEG-2 Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\mpeg2_dec_filter.d

ll

  Intel« Media SDK MP4 Splitter :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_mp4_spl_ds.dll

 

  Intel« Media SDK MPEG-2 Muxer :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_mp2_mux_ds.dll

 

  Intel« Media SDK MP4 Muxer :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_mp4_mux_ds.dll

 

  Intel« Media SDK H.264 Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_build\x64\Debug\h264_dec_f

ilter.dll

  Intel« Media SDK MP3 Encoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_mpa_enc_ds.dll

 

  Intel« Media SDK AAC Encoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\imc_aac_enc_ds.dll

 

  Intel« Media SDK MPEG-2 Encoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\mpeg2_enc_filter.d

ll

  Intel« Media SDK VC-1 Decoder :

    C:\Program Files\Intel\Media SDK 2013 R2\samples\_bin\x64\vc1_dec_filter.dll

 

 

Installed Intel Media Foundation Transforms:

  Intel« Hardware VC-1 Decoder MFT : {059A5BAE-5D7A-4C5E-8F7A-BFD57D1D6AAA}

  Intel« Hardware H.264 Decoder MFT : {45E5CE07-5AC7-4509-94E9-62DB27CF8F96}

  Intel« Hardware MPEG-2 Decoder MFT : {CD5BA7FF-9071-40E9-A462-8DC5152B1776}

  Intel« Quick Sync Video H.264 Encoder MFT : {4BE8D3C0-0515-4A37-AD55-E4BAE19AF

471}

  Intel« Hardware Preprocessing MFT : {EE69B504-1CBF-4EA6-8137-BB10F806B014}

 

 

 

Analysis complete... [press ENTER]

0 Kudos
Highlighted
14 Views

Hi, 

Thank you for the logs. The current system you are running applications on is 2nd gen Sandybridge system and is very old. We regularly update MediaSDK through our graphics drivers with new fixes and some API functions require minimum hardware support. Please consider running your applications on systems on 3rd gen and above. 

In regard to tracer, as you are have multiple older versions of MediaSDK. The older tracer is working due to applications  are still linked to SDK dispatcher from previous versions of SDK. Hence when the new tracer from latest media_sdk_6.0.0.349 package is used, it is not logging SDK functions. This is one of known limitations with tracer. Please refer to "readme-mediasdk-tracer.pdf". 

 Thanks,

0 Kudos
Highlighted
Beginner
14 Views

Hi Harsh:

     Following up on the Tracer issue;  the fact that on startup of Tracer it doesn't even do the 128 Kbytes I don't think would have anything to do with what version of the samples I'm running since at that point I haven't even started my application!!!  There is something wrong with Tracer or the way it is registered!!  Also I was able to make the sample_full_transcode   run using the 6.0.0.049 sample package.  So the cpu is not at issue;  and since that is running from the latest sample package, the latest version of Tracer should work with it; instead the old version works and as I mentioned the latest Tracer won't even do the 128K bytes before I even start the sample_full_transcode   app.

    See what you can discover about this issue since none of this behavior makes much sense!!

   As to the CPU issue, even-though it is a Sandy Bridge the programs always have the option of running in full software mode so I don't think that is at issue either.  I will upgrade to Skylake when it becomes available the late this year  (though I expect that to be mainly a performance improvement as far as QuickSync is concerned not a major functional change).  You might want to pass on to the product people, that your promotional for the professional version  ends August 31  (probably not in time for Skylake);  they might consider extending that date.  Transferring the license to a new computer is a big hassle, especially since Windows 10 will be in play, and since if the problems I'm having with older/newer versions of the SDK most people wouldn't want to risk breaking code that works.

   Mags

 

0 Kudos
Highlighted
14 Views

Hi,

Also I was able to make the sample_full_transcode   run using the 6.0.0.049 sample package -> Glad the sample_full_transcode is working with latest samples package.

In regard to Tracer, there were few changes made to tracer tool in latest update. Yes, it will no longer show 128Kbytes before startup similar to old version of tracer. This was made to display or show exact amount of data written to log file from start to stop. Also to check, when you ran sample_full_transcode did the latest tracer not log any data to the file after you clicked stop after trascode was completed? Let me know.

Previously, I mentioned on running applications on systems on 3rd gen and above as a suggestion, as your applications can use hw support with performance improvement on SDK API 1.5 to API 1.15 features. Yes, we always provide option of running in full Software mode and you can choose at your behest. 

Thank you for your inputs. I will pass it on to the team and great to hear that you will upgrading to Skylake. All the newer versions of SDK have backward compatibility and support previous versions. Please let me know if you have any questions/issues and we can help resolve. 

Thanks,

 

0 Kudos
Highlighted
Beginner
14 Views

Hi  Harsh:

      The Tracer from INDE  version media_sdk_6.0.0.308, is dated 9/19/2014  works fine on the " sample_full_transcode"    .  It tries to write to "analyzer.log file".  It also writes the 128K bytes on startup before I run the sample.

        The Tracer from INDE  version media_sdk_sdk_6.0.0.349 is dated 3/20/2015 fails to write any Kbytes when I run  "sample_full_transcode"   .  It tries to write to" tracer.log file".  It  writes 0 Kbytes on startup before I run the sample.  In the directory where the Tracer.exe is it has a file   ".mfxtracer" (that none of the other Tracer directories have) that contains:

[core]
  level = default
  log = "C:\Users\sm\AppData\Roaming\Intel\SDK_Tracer\tracer.log"
  type = file
  lib = none

       Neither of the Tracer.exe-s have  has a version number at the top.  Both allow the option of "Append to existing file" 

    The old Tracer from Media SDK 2013 R2,  which also works, is dated 6/21/2013 is Intel Media SDK Tracer 4.0.  There is no option  "Append to existing file" .

    I hope this all helps.

    Mags

0 Kudos
Highlighted
14 Views

Hi,

Thank you for sending us the details. This definately helps. To resolve tracer issue and so that I can align on the same configuration of the tracer you are using, for now lets keep focus only to tracer with latest mediaSDK ver 6.0.0.349 package. Let me know what is the result from  following steps.

1) Run the tracer in admin mode. Click Start. Kbytes written =0.

2) Run the full_transcode_sample in sample ver. 6.0.0.049.

3) During transcode process, does the number (Kbytes written) increase? Let me know, what happens.

4)After the transcode process is complete. Do you see tracer.log generated at the location you have assigned in tracer tool? do you see data (SDK API functions) logged in tracer.log ? Please let me know if the tracer.log file is blank (or) missing .

Thanks,

 

0 Kudos
Highlighted
Beginner
14 Views

Hi  Harsh:

   from above:

    1,   Kbytes  written  =0

    2,3   Kbytes written does not increase  (remains at 0)

     4,  Tracer.log  is not written;  file is missing

       Mags

 

 

0 Kudos
Highlighted
14 Views

Hi,

Thank you for testing and letting me know the results. Now, I am able fully understand the issue and we had similar issue before with other customers with several MSDK versions installed, my best workaround suggestion is unstalling all the previous versions  of Media SDK and installing fresh copy latest MediaSDK version. This resolved the issue previously. I understand it will be a bit hazzle to clean cup, but latest version of MediaSDK is compatible and supports all the previous MediaSDK API versions. In meantime, will provide your findings to our team.

Thanks, 

0 Kudos
Highlighted
Beginner
14 Views

Hello Harsh!

I realize this is an old thread but it relates to my current problem. I see the exact same behaviour on my 4th gen Intel box with Win 7 x64, Intel Media SDK 2016 (only, no other versions installed, now or previously). No matter what I do I cannot get the tracer to work. Starts out at "0 bytes written" (to the log) and regardless of how many tasks using the GPU (QS in this case) I perform I get 0 data in the log file. Can you please propose some actions to take from this point.

Would happily provide any information on my system, installed software etc.

0 Kudos
Highlighted
14 Views

Hi Filip, 

Please start a new thread on Media forum as it will be easier for us to track and resolve your issue specifically, with following details: 

1)  Please share a log from system analyzer tool: https://software.intel.com/en-us/articles/media-sdk-tools. 

2) Can you try capturing tracer log by running one of the samples: https://software.intel.com/sites/default/files/MediaSamples_Windows_6.0.0.68.msi? let me know results, if tracer still fails to capture?

3) If you are using your own application, please share details on application use case scenario like. video processing operations (decoding, encoding etc.)? 

Thanks, 

 

 

0 Kudos