Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
63 Views

QuickSync functionality broken with driver automatically deployed by microsoft (25.20.100.6323)

Hello,
I read this:https://software.intel.com/en-us/forums/intel-media-sdk/topic/800921 and I have a similar but not the same bug:

The "old" WHQL driver which was automatically deployed by windows update was "21.20.16.4727".
Everything is working fine with this driver.
Now a new driver is automatically deployed by windows update: 25.20.100.6323.
When we use the old driver (manually restored) our application works fine, the "sample_encode" sample works fine and the application "handbrake" can use Quicksync HW for encoding videos.
When using the new driver: Our application crashes, the "sample_encode" crashes too and "handbrake" uses a software fallback for encoding videos with QuickSync.
I compiled "sample_encode" with latest "Media SDK 2018 R2" installation. Everything("dispatcher binary") is used directly from the installation folder.

The target compute has "i5-6500" cpu and a Q170 Express chipset. There is one additional grafic adapter in system. ("Matrox Orion HD"). The intel grafics adapter is the "primary adapter" set by bios. The os is Windows 10/64 LTSC 1607.

The auto deployment of the driver is a big issue. How can we fix / workaround it in our software (or sample_encode) ?

 

 

0 Kudos
23 Replies
Highlighted
Moderator
63 Views

Hi Mario,

Hi Mario,

If you look at that post, their driver version is 25.20.100.6444, and this version is aligned with we posted in the public, it was called DCH driver in the post you mentioned:

https://www.pcworld.com/article/3323367/hardware/intel-publishes-its-first-modern-windows-driver-for...

I believe your target processor should be following:

https://ark.intel.com/products/88184/Intel-Core-i5-6500-Processor-6M-Cache-up-to-3-60-GHz- ;

Mark

0 Kudos
Highlighted
63 Views

Hello Mark,I downloaded the

Hello Mark,
I downloaded the laatest media sdk samples and recompiled the mfx_dispatch project with vs 2013.
I replaced the "libmfx.lib" in lib\x64 with the new one and recompiled the whole Intel sample sample_encode project.
It still doesnt work. How can I fix the official intel sample when using the official intel driver which is enforced by windows update?
Please that we dont have the "Windows 10 October 2018 Update" installed because it is the Windows 10 long term version. Actually the idea was to get only updates and drivers which are really stable!

0 Kudos
Highlighted
Beginner
63 Views

Are you building code against

Are you building code against it Mario, i.e. do you have access to the source?  My initial attempt at solving this problem was to write some dumb code to get the correct adapter, as follows:
 

{
	IDXGIFactory *pFactory = nullptr;

	CreateDXGIFactory(__uuidof(IDXGIFactory), (void **)&pFactory);

	IDXGIAdapter *pAdapter = nullptr;

	for (UINT i = 0; pFactory->EnumAdapters(i, &pAdapter) != DXGI_ERROR_NOT_FOUND; ++i)
	{
		DXGI_ADAPTER_DESC desc;

		pAdapter->GetDesc(&desc);
		pAdapter->Release();

		if (wcsncmp(desc.Description, L"Intel", 5) == 0)
		{
			My_QSV_Adapter_Number = i;

			break;
		}
	}

	pFactory->Release();
}

, instead of the loop described in the sample for identifying the correct adapter.  However the new dispatcher did work for us, so this wasn't needed in the end.

 

0 Kudos
Highlighted
63 Views

Hi UK,

Hi UK,

thank you for sharing the code. What do you mean with "the new dispatcher". I just compiled the official intel sample "sample_encode" with the latest official intel media sdk. I have full access to the code of course. There is no additional dispatcher. Can you provide an url ?
Additionally i believe that the issue is  not related to the "adapter issue". It also doesnt work if we remove the second grafic adapter.

@Mark Could you provide a working "sample_encode" sample please ?

Best,

Mario


 


 

 

 

0 Kudos
Highlighted
63 Views

Hi Mark,

Hi Mark,

Maybe I didn't explain it right.
Do you agrre that the driver published by microsoft update (Windows 10 1607 LTSC) version is 25.20.100.6323?

There is no new driver available from microsoft update. (Updating manually is not an option)
Can you confirm that this is an bug inside the driver? or inside the intel media sdk?
How can I fix the bug /issue ?

Best,
Mario

 


 

0 Kudos
Highlighted
63 Views

Hi Mario,

Hi Mario,

We checked sample_encode with driver 25.20.100.6323 installed on win10 1607 and didn't face any issue.

Could you please try to reinstall this driver manually and check if sample_encode works?

https://downloadcenter.intel.com/download/28180/

Also could you share command line you use to run sample_encode and its log when it fails?

0 Kudos
Highlighted
63 Views

Hi Nikita,did you try to

Hi Nikita,
did you try to reproduce it on "WIn10 LTSC (formally known as LTSB) 1607" ?

We will try to reinstall the driver manually today.
The call for sample_encode is:
sample_encode.exe h264 -i test_stream_176x96.yuv -o out.h264 -w 176 -h 96
 

Best,

Mario

0 Kudos
Highlighted
63 Views

Hello Nikita,

Hello Nikita,

we also tested it Now on windows 10 pro:
There are no problems with driver "6323" on "windows 10 pro 1607" and "windows 10 pro 1803"!
We also noted noted that the driver version is different from windows 10 1607 ltsb. On LTSB we get 6323 from microsoft update. With win10 pro we get "25.20.100.6373" from windows update. (But we also tested 6323 on win10 pro)

This means that there is a problem/issue with driver 6323 only at windows 10 LTSB 1607. (For now it is unknown if there is a problem with newer LTSB versions of windows)
Best regards,

Mario


 

0 Kudos
Highlighted
63 Views

Hi Mario,

Hi Mario,

We were able to reproduce your issue on Win 10 LTSB 1607. We are working on figuring out the cause.

0 Kudos
Highlighted
63 Views

Hi Nikita,

Hi Nikita,

thank you for working on the issue. Hopefully you will find a solution or convenient workaround!

Best,

Mario

 

0 Kudos
Highlighted
Moderator
63 Views

Hi Mario,

Hi Mario,

I am asking the dev team and will give you update soon.

Mark

0 Kudos
Highlighted
Moderator
63 Views

Hi Mario,

Hi Mario,

I have asked dev team and they have a fix to it.

I am confirming the release schedule now.

Mark

0 Kudos
Highlighted
63 Views

Hi Mark,

Hi Mark,

thank you and the team!

 

Best regards

Mario

0 Kudos
Highlighted
Beginner
63 Views

Hi Mark,

Hi Mark,

 

I was facing a similar issue with 6323 on "windows 10 pro 1607 

So would like to know how exactly will the fix be rolled out and how I can get it ?

Will that be a part of Windows update ?

 

Regards,

Ajesh

0 Kudos
Highlighted
Moderator
63 Views

Hi Mario and Ajesh,

Hi Mario and Ajesh,

Sorry for the slow response, it looks like the fix will be released after a month. So please check the new driver release after a month and let us know if it fix the issue.

Mark

0 Kudos
Highlighted
Beginner
63 Views

Hi Mark,

Hi Mark,

I checked the intel driver download site: https://downloadcenter.intel.com/download/28180/ . But, I don't see any driver updates posted so far for this issue. Can you provide latest information on when we can expect an updated driver?

-Arun-

0 Kudos
Highlighted
Moderator
63 Views

Hi Arun,

Hi Arun,

I don't know and I am checking it with dev team.

Mark

0 Kudos
Highlighted
Beginner
63 Views

Hi Mark,

Hi Mark,

Can you please let us know when we can expect this release. It is more than a month since you confirmed that the fix will be released.

Thanks,
Shiv

0 Kudos
Highlighted
Moderator
63 Views

Yes and sorry for the late

Yes and sorry for the late response, dev team told me this fix is updated in driver 26.20.100.6708 

Let me know if the issue is fixed by this driver.

Mark

0 Kudos