Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Song__Gibeom
Beginner
159 Views

Segmentation fault of vainfo on ubuntu 16.04 with MediaServerStudioEssentials2017R3

 

Hello, I'm trying to install a Mediasdk but I'm a beginner of Intel mediasdk so I followed this reference and used MediaServerStudioEssentials2017R3. 

My hardware and OS infomation is like that:

Processor : Intel Atom x5-Z8350 ( Cherrytrail)

OS: Ubuntu 16.04 

 

my vainfo command result is incorrect like that 

libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.99 (libva 1.67.0.pre1)
vainfo: Driver version: 16.5.2.64009-ubit
vainfo: Supported profile and entrypoints
      VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:    VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:    <unknown entrypoint>
      VAProfileH264ConstrainedBaseline:    <unknown entrypoint>
      VAProfileH264Main               :    VAEntrypointVLD
      VAProfileH264Main               :    VAEntrypointEncSlice
      VAProfileH264Main               :    <unknown entrypoint>
      VAProfileH264Main               :    <unknown entrypoint>
      VAProfileH264High               :    VAEntrypointVLD
      VAProfileH264High               :    VAEntrypointEncSlice
      VAProfileH264High               :    <unknown entrypoint>
      VAProfileH264High               :    <unknown entrypoint>
      VAProfileMPEG2Simple            :    VAEntrypointEncSlice
      VAProfileMPEG2Simple            :    VAEntrypointVLD
      VAProfileMPEG2Main              :    VAEntrypointEncSlice
      VAProfileMPEG2Main              :    VAEntrypointVLD
      VAProfileVC1Advanced            :    VAEntrypointVLD
      VAProfileVC1Main                :    VAEntrypointVLD
      VAProfileVC1Simple              :    VAEntrypointVLD
      VAProfileJPEGBaseline           :    VAEntrypointVLD
      VAProfileJPEGBaseline           :    VAEntrypointEncPicture
      VAProfileVP8Version0_3          :    VAEntrypointEncSlice
      VAProfileVP8Version0_3          :    VAEntrypointVLD
      VAProfileVP8Version0_3          :    <unknown entrypoint>
      VAProfileVP9Profile0            :    <unknown entrypoint>
      <unknown profile>               :    VAEntrypointVideoProc
      VAProfileNone                   :    VAEntrypointVideoProc
      VAProfileNone                   :    <unknown entrypoint>
Segmentation fault (core dumped)

I don't know how could I solve this problem. 
Please help me.  

0 Kudos
6 Replies
Mark_L_Intel1
Moderator
159 Views

Hi Geobiem,

Media SDK requires the hardware in our GPU to support its hardware video acceleration functions, AKA, Quick Sync Video. After checking the following spec, I don't think your hardware has this functional hardware.

https://ark.intel.com/content/www/us/en/ark/products/93361/intel-atom-x5-z8350-processor-2m-cache-up...

I think this is why you got a failure in the driver layer.

Mark

Song__Gibeom
Beginner
159 Views


Hi Mark, 

I saw your reference. Maybe, x5-Z8350 is looked to be not appropriate for MediaSDK.

By the way, many video player in ubuntu ( MPV player, VLC player, etc) works using Intel graphics without Mediasdk driver well. Very smoothly. 

I want to make a fast video player like MPV, VLC. 

Could you teach or give me some advice or a reference? how could I make smooth video playback without MediaSDK ( i.e direct-call vaapi, etc) 

 

Thanks to your comment. 

 

Dmitry_E_Intel
Employee
159 Views

Hi Geobiem,

 

What is graphics device id?

lspci -nn | grep VGA

 

Regards,

Dmitry

Mark_L_Intel1
Moderator
159 Views

Hi Geobiem,

Sorry for the confusion, the cause to the failure won't change but after double checking the spec, Cherrytrail does have the hardware codec; the problem is the software, our driver doesn't support this processor and it is very hard for us to change the code.

So VAAPI via i915 doesn't work, one other thing you can try to use i965 via standard VAAPI path although I never try it before.

Please also forward the device ID as Dmitry requested.

Mark

Song__Gibeom
Beginner
159 Views

 

Hi Dmitry, 

my graphics device id is like that

root@lattepanda:~/opencv# lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b0] (rev 36)

 

Thank you. 

Song__Gibeom
Beginner
159 Views

 

Hi Mark, 

I see. I will try to search on how to use i965.

Thank you. 

Best regards, 

Reply