Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bono
Beginner
105 Views

Skylake support on Linux Slackware

I have just bought new server with skylake processor version: E3-1275V5 which I cannot get to work with media on Slackware.

I see that drivers for skylake GPU is included in kernel version: 3.19, but media encoder installer says that it needs kernel 3.14.5 to properly work.

What can i do to fix that is there any custom drivers which I can compile on kernel 3.14.5 and that will work with gpu drivers on my skylake cpu.

Thank you.

0 Kudos
3 Replies
Surbhi_M_Intel
Employee
105 Views

Hi Bono, 

Media Server Studio has not release SKL support yet, so there are no kernel patches publicly available to apply and use quick sync video. The last patches are available on kernel 3.14.5 which is part of Media Server Studio 2015 R6 package. 

Thanks,
Surbhi

Bono
Beginner
105 Views

Do you have any ETA when it will be available? It was really hard to find haswell cpu that is why I bought skylake.

 

Peter_F_3
Beginner
105 Views

The deployment story is really quite the nightmare for MSS - as it stands it is impossible to distribute pure software projects, since MSS requires hacks against the host operating system to function.  And extremely limited kernel version compatibility means that developers may be wedged by missing/poor hardware support in the compatible kernel, making it impossible to use MSS in combination with other devices (short of trying to backport other driver code, where that's even possible).

Is there actually good reason why MSS kernel code (and for that matter, libva/libdrm/etc) can't be upstreamed?  Intel already has engineers with good standing in these projects.

Reply