Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jason_Y_
Beginner
64 Views

Some problem for decode raw H264 stream file

Hi All,

I've got the some problem with MFXVideoDECODE_DecodeHeader, in the Media SDK 2014, sample_decode.

(file:pipeline_decode.cpp, function: InitMfxParams)

When I decode a raw h264 stream file with sample_decode, using the params as"h264 -i in.h264 -o out.yuv -hw -calc_latency", the decoder will be entry the endless loop for "DecodeHeader" in the function "CDecodingPipeline::InitMfxParams". But when I use the params as "h264 -i in.h264 -o out.yuv -hw", it works well.  

And I found that the object "m_FileReader" will be set as "CH264FrameReader" when using -calc_latency , otherwise it will be set as "CSmplBitstreamReader" .

How can I fix the problem?

0 Kudos
3 Replies
64 Views

Hi Jason, I ran the decode sample with the same parameters as you, and I am not able to reproduce the issue. My decoding works fine with the parameters, and I get the latency output as well.

What is the OS and system you are running on? I ran mine on Win 8.1, and on both Intel Core i5-4300U CPU and Xeon CPU E3-1285 V2.

Jason_Y_
Beginner
64 Views

Hi SRAVANTHI, I ran it on Win 7, Intel Xeon CPU E3-1245 V3 with intel media sdk 2014 r2 for clients. And Linux SUSE* Linux* Enterprise Server 11 for 64-bit architecture with Media sdk 2014 for linux server. Neither ran properly.

I rewrite the function  "CDecodingPipeline::InitMfxParams"  tried to read Multi Frame(such as more than 1024K bytes stream data) when "DecodeHeader", then it works well. So maybe the function "DecodeHeader" need more stream data.

64 Views

Hi Jason, Glad you found a work around for the issue you are facing. And yes, the systems you mention above are supported and tested. We usually test our sample codes on input streams from bigbuckbunny or tearsofsteel. Would you please test your application with streams from one of these and let us know the status? Thanks!

And thanks for bringing the buffer size issue to our notice. 

Reply