Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools from Intel. This includes Intel® oneAPI Video Processing Library and Intel® Media SDK.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

Support for Atom X6425E processors in Linux

Kimi_liu
Beginner
637 Views

Hardware: Atom X6425E processors,
OS: Ubuntu 20.04,  kernel: 5.15.0-52-generic.


After installing Intel Media SDK 22.5.4, the 'sample_encode' program does not run properly. The error return value is as follows:

333.png

Does the x6425E processor not support the Linux version of the Intel Media SDK?

0 Kudos
8 Replies
RemyaP_Intel
Moderator
549 Views

Hi,


Thank you for posting in Intel Communities.


Could you please confirm the Media SDK version? In the screenshot shared, it is showing 21.2.3



Regards,

Remya Premdas




Kimi_liu
Beginner
514 Views
Thanks for your reply.
 
I used Intel MediaSDK 2022Q3 Release - 22.5.4 and Intel Media SDK 21.2.3 respectively and running the sample encode program both returned 'MFX_ERR_UNSUPPORTED(-3)'.

Also, I looked at the source code of libmfx and found out the problem. 
As shown below, for 'H264' encoder, the encoder parameters 'mfx.RateControlMethod', currently only 'CQP' is supported, the others are not. So the default parameter is used to return an error.

 

Kimi_liu_2-1669259120292.png

 

I would like to know if this is normal on the x6425e processor? (CQP support only)
 
At the same time, the H265 encoding has the same problem of not working.
Kimi_liu_5-1669259181369.png

 

RemyaP_Intel
Moderator
486 Views

Hi,


Sorry for the inconvenience. We are working on this internally. We will get back to you with an update.


Regards,

Remya Premdas


Kimi_liu
Beginner
456 Views

Thanks,
I look forward to receiving your reply.

RemyaP_Intel
Moderator
402 Views

Hi,

 

We were able to run sample_encode on oneVPL HW implementation . Could you please switch to oneVPL and try running the sample?

root@9049fa065fa6:~/samples_test/oneVPL/examples/hello/hello-encode# sample_encode h265 -hw -i ../../content/cars_320x240.nv12 -w 320 -h 240 -cqp -qpi 10 -qpb 30 -qpp 30 -g 30 -o output.h265
CONFIGURE LOADER: required implementation: hw
CONFIGURE LOADER: required implementation mfxAccelerationMode: MFX_ACCEL_MODE_VIA_VAAPI
libva info: VA-API version 1.15.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_15
libva info: va_openDriver() returns 0
libva info: VA-API version 1.15.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_15
libva info: va_openDriver() returns 0
Loaded Library configuration:
    Version: 2.7
    ImplName: mfx-gen
    Adapter number : 0
    Adapter type: integrated
    DRMRenderNodeNum: 128
Used implementation number: 0
Loaded modules:
   0: /root/samples_test/oneVPL/lib/libvplswref64.so.1
   1: /usr/lib/x86_64-linux-gnu/libmfx-gen.so.1.2.7
   2: /usr/lib/x86_64-linux-gnu/libmfxhw64.so.1.35libva info: VA-API version 1.15.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_15
libva info: va_openDriver() returns 0
Encoding Sample Version 8.4.27.0Input file format       YUV420
Output video            HEVC
Source picture:
        Resolution      320x240
        Crop X,Y,W,H    0,0,320,240
Destination picture:
        Resolution      320x240
        Crop X,Y,W,H    0,0,320,240
Frame rate      30.00
QPI     10
QPP     30
QPB     30
Gop size        30
Ref dist        0
Ref number      0
Idr Interval    0
Target usage    balanced
Memory type     system
Media SDK impl          hw
Media SDK version       2.7Processing started
Frame number: 30
Encoding fps: 1233Processing finished 

Thanks,

Remya Premdas

 

 

 

RemyaP_Intel
Moderator
316 Views

Hi,


We haven't received any update from your end. Were you able to run the sample code?


Regards,

Remya Premdas


Kimi_liu
Beginner
307 Views

Thank you for your reply.

I did not switch to oneVPL and try to run the sample.

 

I switched my ubuntu system to intel-iot Ubuntu 20.04.5 and retried the Media SDK and now I can run the sample program properly.

 

 I think this may have something to do with the kernel of the Ubuntu distribution, and I will now continue to develop with the Media SDK on intel-iot Ubuntu 20.04.5.

 

Thanks again

RemyaP_Intel
Moderator
303 Views

Hi,


Glad to know that your issue is resolved. Thanks for sharing the solution with us. If you need any additional information, please post a new question as this thread will no longer be be monitored by Intel.


Regards,

Remya Premdas


Reply