Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NAves
Novice
42 Views

Ubunut MSDK 2015

Hi
Installed media sdk on base Ubuntu 14.04, with i7-4760HQ, running 3.8 kernel:

# uname -r
3.8.0-23-generic


#clinfo

Name:                         Intel(R) Core(TM) i7-4760HQ CPU @ 2.10GHz
  Vendor:                     Intel(R) Corporation
  Device OpenCL C version:             OpenCL C 1.2

Platform ID:                     0x7f7146e5b920
  Name:                         Intel(R) HD Graphics Haswell CRW GT3 Mobile
  Vendor:                     Intel
  Device OpenCL C version:             OpenCL C 1.2 beignet 0.9.3

Followed the  ./install.sh path, without any problems. After reboot verified correct kmd:

# lsmod | grep i915
i915                  617480  2
drm_kms_helper         49196  1 i915
drm                   285862  3 i915,drm_kms_helper
i2c_algo_bit           13564  1 i915
video                  19652  1 i915

# dpkg -l | grep intel
ii  intel-gpu-tools                                       1.3-0ubuntu2.1                                          amd64        tools for debugging the Intel graphics driver
iU  intel-linux-media-dev-ubuntu                          16.3.2.22368                                            amd64        Dev package of An Intel implementation of the DRI driver.
ii  intel-linux-media-ubuntu                              16.3.2.22368                                            amd64        An Intel implementation of the DRI driver - DRM backend.
ii  libdrm-intel1:amd64                                   2.4.52-1                                                amd64        Userspace interface to intel-specific kernel DRM services -- runtime
ii  xserver-xorg-video-intel                              2:2.99.910-0ubuntu1.1                                   amd64        X.Org X server -- Intel i8xx, i9xx display driver

Rebuilt the sample directory without any errors:

make[2]: Leaving directory `/opt/intel/mediasdk/samples/__cmake/intel64.make.release'
/usr/bin/cmake -E cmake_progress_report /opt/intel/mediasdk/samples/__cmake/intel64.make.release/CMakeFiles  74 75 76 77 78 79 80 81 82 83 84 85 86 87
[100%] Built target sample_full_transcode_x11
make[1]: Leaving directory `/opt/intel/mediasdk/samples/__cmake/intel64.make.release'
/usr/bin/cmake -E cmake_progress_start /opt/intel/mediasdk/samples/__cmake/intel64.make.release/CMakeFiles 0

[ intel64.make.release                               State: OK   ]

Verified proper library path:
# ldd ./sample_encode_drm
    linux-vdso.so.1 =>  (0x00007fff96db4000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fa22176e000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fa221550000)
    libva.so.1 => /usr/lib/x86_64-linux-gnu/libva.so.1 (0x00007fa221339000)
    libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007fa22112b000)
    libva-drm.so.1 => /usr/lib/x86_64-linux-gnu/libva-drm.so.1 (0x00007fa220f28000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fa220c23000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fa22091d000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fa220707000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fa220340000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fa22198a000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fa220138000)

However, I am not able to run the sample encoder:
# ./sample_encode_drm h264 -i ~/Videos/BasketballDrive_1920x1080_50.yuv -o ~/Videos/BasketballDrive_1920x1080_50.h264 -w 1920 -h 1080

Return on error: error code -3,    /home/msdk/mdp_msdk-samples/samples/sample_encode/src/pipeline_encode.cpp    947


Return on error: error code 1,    /home/msdk/mdp_msdk-samples/samples/sample_encode/src/sample_encode.cpp    439

Any help would be appreciated.
Cheers,

 

0 Kudos
2 Replies
NAves
Novice
42 Views

Never mind had to add -hw to the cli, Doh:

# ./sample_encode_drm h264 -i ~/Videos/BasketballDrive_1920x1080_50.yuv -o ~/Videos/BasketballDrive_1920x1080_50.h264 -w 1920 -h 1080 -hw
libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
Intel(R) Media SDK Encoding Sample Version 5.0.1603344.93446

Input file format    YUV420
Output video        AVC
Source picture:
    Resolution    1920x1088
    Crop X,Y,W,H    0,0,1920,1080
Destination picture:
    Resolution    1920x1088
    Crop X,Y,W,H    0,0,1920,1080
Frame rate    30.00
Bit rate(Kbps)    3757
Target usage    balanced
Memory type    system
Media SDK impl        hw
Media SDK version    1.10

Processing started
Frame number: 501
Processing finished

 

Cheers,
 

42 Views

Glad you fixed it. The linux versions do not support SW implementation, thus -hw flag is mandatory for running the samples on linux. The help menu for sample applications could be more explicit about this, and give better error messages!

Reply