Community
cancel
Showing results for 
Search instead for 
Did you mean: 
tetsuji_o_
Beginner
94 Views

When I install the Intel Media Server Studio 2017 R3, but error occurred.

I would like to install Intel Media Server Studio 2017 R3 on CentOS7.3.1611.

Environment is as follows.

model name : Intel(R) Core(TM) i7-6770HQ CPU @ 2.60GHz
OS: CentOS Linux release 7.3.1611 (Core)
arch: x86_64
version: Linux version 3.10.0-514.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Tue Nov 22 16:42:41 UTC 2016

I've read the "media_server_studio_getting_started_guide.pdf". But it seems like that Media Server Studio doesn't be installed.

The below is my doing steps.

$ sudo yum -y groupinstall "Development Tools"
$ sudo yum -y install pciutils net-tools autoconf automake cmake freetype-devel gcc gcc-c++ git libtool make mercurial nasm pkgconfig zlib-devel mesa-dri-drivers wget bc
$ sudo usermod -a -G video build
$ su build
$ tar zxvf MediaServerStudioEssentials2017R3.tar.gz
$ cd MediaServerStudioEssentials2017R3
$ tar zxvf SDK2017Production16.5.2.tar.gz
$ cd SDK2017Production16.5.2/CentOS
$ tar zxvf install_scripts_centos_16.5.2-64009.tar.gz
$ su
$ ./install_sdk_CentOS.sh

・・・
--> 依存性の処理をしています: elfutils-libelf(x86-64) = 0.166-2.el7 のパッケージ: elfutils-libelf-devel-0.166-2.el7.x86_64
---> パッケージ graphite2.x86_64 0:1.3.10-1.el7_3 を インストール
---> パッケージ libXfont.x86_64 0:1.5.1-2.el7 を インストール
---> パッケージ libXxf86vm.x86_64 0:1.1.3-2.1.el7 を インストール
---> パッケージ libfontenc.x86_64 0:1.1.2-3.el7 を インストール
---> パッケージ libxshmfence.x86_64 0:1.2-1.el7 を インストール
---> パッケージ mesa-libgbm.x86_64 0:11.2.2-2.20160614.el7 を インストール
---> パッケージ mesa-libglapi.x86_64 0:11.2.2-2.20160614.el7 を インストール
--> 依存性解決を終了しました。
エラー: パッケージ: elfutils-libelf-devel-0.166-2.el7.x86_64 (base)
             要求: elfutils-libelf(x86-64) = 0.166-2.el7
            インストール: elfutils-libelf-0.168-8.el7.x86_64 (@base/7)
                elfutils-libelf(x86-64) = 0.168-8.el7
            利用可能: elfutils-libelf-0.166-2.el7.x86_64 (base)
                elfutils-libelf(x86-64) = 0.166-2.el7
エラー: パッケージ: audit-libs-devel-2.6.5-3.el7_3.1.x86_64 (updates)
             要求: audit-libs(x86-64) = 2.6.5-3.el7_3.1
            インストール: audit-libs-2.7.6-3.el7.x86_64 (@base/7)
                audit-libs(x86-64) = 2.7.6-3.el7
            利用可能: audit-libs-2.6.5-3.el7.x86_64 (base)
                audit-libs(x86-64) = 2.6.5-3.el7
            利用可能: audit-libs-2.6.5-3.el7_3.1.x86_64 (updates)
                audit-libs(x86-64) = 2.6.5-3.el7_3.1
エラー: パッケージ: elfutils-devel-0.166-2.el7.x86_64 (base)
             要求: elfutils-libs(x86-64) = 0.166-2.el7
            インストール: elfutils-libs-0.168-8.el7.x86_64 (@base/7)
                elfutils-libs(x86-64) = 0.168-8.el7
            利用可能: elfutils-libs-0.166-2.el7.x86_64 (base)
                elfutils-libs(x86-64) = 0.166-2.el7
 問題を回避するために --skip-broken を用いることができます。
 これらを試行できます: rpm -Va --nofiles --nodigest
yum install failed!

As there is no repository file on the default CentOS-Base.repo, so I've rewritten the CentOS-Base.repo as below.

# CentOS-Base.repo
#
# The mirror system uses the connecting IP address of the client and the
# update status of each mirror to pick mirrors that are updated to and
# geographically close to the client.  You should use this for CentOS updates
# unless you are manually picking other mirrors.
#
# If the mirrorlist= does not work for you, as a fall back you can try the
# remarked out baseurl= line instead.
#
#

[base]
name=CentOS-$releasever - Base
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra
baseurl=http://vault.centos.org/centos/7.3.1611/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#released updates
[updates]
name=CentOS-$releasever - Updates
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates&infra=$infra
baseurl=http://vault.centos.org/7.3.1611/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras&infra=$infra
baseurl=http://vault.centos.org/centos/7.3.1611/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus&infra=$infra
baseurl=http://vault.centos.org/centos/7.3.1611/centosplus/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

And, I've commanded as below.
 

# yum clean all
# yum update

Then I've tried "./install_sdk_CentOS.sh", but same error occurred.

What's wrong? If you know a solution, let me know it.

Bests,

0 Kudos
0 Replies
Reply