Community
cancel
Showing results for 
Search instead for 
Did you mean: 
234__wsm
Beginner
84 Views

Why vainfo failed, when media server studio installed on CPU( Intel Xeon E3 1225 V5 )?

I have installed Media Server Studio 2017 R3 on CentOS 7.3,  CPU is  Intel Xeon E3 1225 V5 .

[hope@localhost CapsBasic]$ vainfo
libva info: VA-API version 0.99.0
Xlib:  extension "XFree86-DRI" missing on display ":0".
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
vaInitialize failed with error code -1 (unknown libva error),exit

-----------

[hope@localhost Downloads]$ python sys_analyzer_linux.py
--------------------------
Hardware readiness checks:
--------------------------
 [ OK ] Processor name: Intel(R) Xeon(R) CPU E3-1225 v5 @ 3.30GHz
--------------------------
OS readiness checks:
--------------------------
 [ OK ] GPU visible to OS
--------------------------
Media Server Studio Install:
--------------------------
 [ OK ] user in video group
 [ OK ] libva.so.1 found
 [ ERROR ] libva not loading Intel iHD
 [ ERROR ] vainfo not reporting codec entry points
 [ ERROR ] Intel video adapter not using i915
 [ ERROR ] no /dev/dri/renderD* interfaces found
--------------------------
Component Smoke Tests:
--------------------------
 [ OK ] Media SDK HW API level:1.23
 [ OK ] Media SDK SW API level:1.23
 [ OK ] OpenCL check:platform:Intel(R) OpenCL GPU FAIL CPU OK

Please help me.  Thanks.

0 Kudos
1 Reply
Mark_L_Intel1
Moderator
84 Views

Hi WSM,

From python script report, looks like your hardware and OS is OK and I assume you have run the installation successfully. Did you set following environment variables when running "vainfo"?

$ export LIBVA_DRIVERS_PATH=/opt/intel/mediasdk/lib64
$ export LIBVA_DRIVER_NAME=iHD

If this still doesn't work, you can also double check the detailed installation steps with the following document:

https://software.intel.com/sites/default/files/managed/52/a7/media_server_studio_getting_started_gui...

Did you run it manually or with script? The script goes very fast and you might miss some error messages.

Mark