Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MyMother
Beginner
58 Views

decode fail when thread_num equals 1

hi,

OS: Ubuntu 12.04

       MediaSamples_Linux_6.0.16043175.175

       MediaServerStudioEssentials2015R6

Platform:  i5-4570S

I got following error as setting field "threads_num" to 1 ~

[release] $ time ./sample_decode_x11 h264 -hw -low_latency -vaapi -threads_num 2 -i 1080p.264
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
Decoding Sample Version 0.0.000.0000


Input video     AVC
Output format   YUV420
Resolution      1920x1088
Crop X,Y,W,H    0,0,0,0
Frame rate      30.00
Memory type             d3d
MediaSDK impl           hw
MediaSDK version        1.16

Decoding started
Frame number:  635, fps: 1122.763, fread_fps: 0.000, fwrite_fps: 0.000
Decoding finished

real    0m0.574s
user    0m0.238s
sys     0m0.039s
[release] $ time ./sample_decode_x11 h264 -hw -low_latency -vaapi -threads_num 1 -i 1080p.264

Return on error: error code -3, /home/dspuser/Downloads/IntellMediaSDK/MediaSamples_Linux_6.0.16043175.175/samples/sample_decode/src/pipeline_decode.cpp  200                  ==>   -3 means  MFX_ERR_UNSUPPORTED.     Why it's not supported ??? Any concern inside??


Return on error: error code 1,  /home/dspuser/Downloads/IntellMediaSDK/MediaSamples_Linux_6.0.16043175.175/samples/sample_decode/src/sample_decode.cpp  501                  ==> 1 means MFX_WRN_IN_EXECUTION


real    0m0.004s
user    0m0.004s
sys     0m0.000s
[release] $

0 Kudos
4 Replies
Jiandong_Z_Intel
Employee
58 Views

Hi There,

I want to better understand your system.

Can you send following command line ?

$ uname -r

$ ls -l /dev/dri

$ vainfo

You are using Ubuntu 12.04, right ? Just want you know currently CentOS 7.1 is Intel media server studio Gold configuration.

Thanks

Zachary

MyMother
Beginner
58 Views

Hi Here,

[release] $ uname -r
3.14.5
[release] $ ls -l /dev/dri/
total 0
crw-rw----+ 1 root video 226,   0 Dec 16 01:48 card0
crw-rw----  1 root video 226,  64 Nov 13 02:07 controlD64
crw-rw----  1 root video 226, 128 Nov 13 02:07 renderD128
[release] $ sudo vainfo
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.1)
vainfo: Driver version: 16.4.2.1.39163-ubit
vainfo: Supported profile and entrypoints
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileNone                   : <unknown entrypoint>
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264Baseline           : VAEntrypointEncSlice
      VAProfileH264Baseline           : <unknown entrypoint>
      VAProfileH264Baseline           : <unknown entrypoint>
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : <unknown entrypoint>
      VAProfileH264Main               : <unknown entrypoint>
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : <unknown entrypoint>
      VAProfileH264High               : <unknown entrypoint>
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: <unknown entrypoint>
      VAProfileH264ConstrainedBaseline: <unknown entrypoint>
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : <unknown entrypoint>
[release]

 

You are using Ubuntu 12.04, right ? Just want you know currently CentOS 7.1 is Intel media server studio Gold configuration.

> Yes, thanks  @@y

Thank you

 

Jiandong_Z_Intel
Employee
58 Views

Hi Medwin,

Thank you report this issue. I can reproduce this issue, I will check with develop team and get back to you.

Thanks,

Zachary

 

Jiandong_Z_Intel
Employee
58 Views

This is a feature, it is not a bug, so close this thread.

Reply