Community
cancel
Showing results for 
Search instead for 
Did you mean: 
liujun_l_
Beginner
61 Views

decode sample failure on my yoga3 pro

Jump to solution

Hi,

I'm trying to run the sampe_decode in INDE, my hardware is Core M5y70, graphic is HD5300, OS win8.1, the sample version I used is

Intel Media Samples 6.0.0.49,  the driver I downloaded is win64_153619.exe.

 

my runtime parameter is set as

h265 -i 1080p_Big_buck_bunny_1080p_f619.bin -o test.yuv -hw -p 33a61c0b4c27454ca8d85dde757c6f8e

the input stream I used is compressed with x265 in videoLan, with the default setting.

but I got the following failure:

plugin_loader.h :157 [INFO] Plugin was loaded from GUID

Return on error: error code -3, src\pipeline_decode.cpp 641

Return on error: error code -3, src\pipeline_decode.cpp 287

Return on error: error code 1,  src\sample_decode.cpp   496

plugin_loader.h :183 [INFO] MFXBaseUSER_UnLoad(session=0x000000FD9EF735C0), sts=
0

I checked that -3 is unsupported feature, does it mean my hardware not support this feature, or I did something wrong? 

 

thanks

0 Kudos
1 Solution
61 Views

Hi,

Thank you for the logs. Your hw does not support this feature. The current hardware you are using (5Y70 CPU) does not provide hw hevc decode support which is via our graphics driver. You can hevc hw decode on system other than (5Y**) series processors. 

Thanks,

View solution in original post

3 Replies
61 Views

Hi,

Can you send us a log from system analyzer < mediaSDK/tools/system analyzer>, so we have all the available information about the system.

Also, I tried with one of the our input test (Bigs Bunny) elementary stream file and did not see this issue, Can you  please try with any other .265 test input file you have, just to isolate issue seen is not due to input file.  Let me know if that works! 

Thanks,

liujun_l_
Beginner
61 Views

Hi,

I tried another 3 more, all of them has this  issue, they can be decode by OpenHEVC, so I think the input stream is fine.

I've attached the log by the sys analysis tool.

62 Views

Hi,

Thank you for the logs. Your hw does not support this feature. The current hardware you are using (5Y70 CPU) does not provide hw hevc decode support which is via our graphics driver. You can hevc hw decode on system other than (5Y**) series processors. 

Thanks,

View solution in original post

Reply