Community
cancel
Showing results for 
Search instead for 
Did you mean: 
derguteweka
Beginner
88 Views

different Audio on different HDMI/DP ports possible?

Hi All,

Having an embedded PC-Board here with 1x DP output and 1x eDP output. On both there's video OK. But i fail to get different audio over the 2 (e)DP lines. Or audio at all over the 2nd eDP link. I'm not using any pulseaudio, gstreamer or other "hi-level" audiotools, just plain Alsa.

root [ ~ ]# aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CS4207 Analog [CS4207 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CS4207 Digital [CS4207 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

 

Outputting a wav file to analog output works OK with: aplay -D hw:0,0 sine.wav

Outputting a wav file to one DP also works OK with: aplay -D hw:0,3 sine.wav

But i get exactly the same result, when i use 7 or 8 instead of 3 in the command. Audio comes always via the same DP connection. Never from the other. How can i get audio over the other DP connection? On both DP links, there's the same type of device connected (CH7515), but just one has audio.

More info:

According to Xorg.0.log, both Displays are connected to: eDP1 and DP1.

I'm using the iHD Driver; but problem stays the same if there's just plain textmode; and no Xorg running.

Kernel is plain vanilla 4.12.7.

Alsa-lib: 1.1.4.1; Alsa-Utils: 1.1.4; no /etc/asound.conf or any other tweaking file.

Any advice would be appeciated.

WK

 

0 Kudos
0 Replies
Reply