Community
cancel
Showing results for 
Search instead for 
Did you mean: 
rshal2
New Contributor II
82 Views

install_sdk_UMD_CentOS.sh errors

Jump to solution

Hello,

 

I am following the exact instruction for install of media sdk server, but I get the below errors.

Can anyone please assist ?

[root@localhost CentOS]#
[root@localhost CentOS]# ./install_sdk_UMD_CentOS.sh
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.syn.co.il
 * extras: centos.syn.co.il
 * updates: centos.syn.co.il
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.syn.co.il
 * extras: centos.syn.co.il
 * updates: centos.syn.co.il
Package kernel-headers-3.10.0-327.3.1.el7.x86_64 already installed and latest version
Package kernel-devel-3.10.0-327.3.1.el7.x86_64 already installed and latest version
Nothing to do
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.syn.co.il
 * extras: centos.syn.co.il
 * updates: centos.syn.co.il
Package bison-2.7-4.el7.x86_64 already installed and latest version
Package ncurses-devel-5.9-13.20130511.el7.x86_64 already installed and latest version
Package hmaccalc-0.9.13-4.el7.x86_64 already installed and latest version
Package zlib-devel-1.2.7-15.el7.x86_64 already installed and latest version
Package binutils-devel-2.23.52.0.1-55.el7.x86_64 already installed and latest version
Package elfutils-libelf-devel-0.163-3.el7.x86_64 already installed and latest version
Package rpm-build-4.11.3-17.el7.x86_64 already installed and latest version
Package redhat-rpm-config-9.1.0-68.el7.centos.noarch already installed and latest version
Package asciidoc-8.6.8-5.el7.noarch already installed and latest version
Package hmaccalc-0.9.13-4.el7.x86_64 already installed and latest version
Package perl-ExtUtils-Embed-1.30-286.el7.noarch already installed and latest version
Package pesign-0.109-9.el7.x86_64 already installed and latest version
Package xmlto-0.0.25-7.el7.x86_64 already installed and latest version
Package audit-libs-devel-2.4.1-5.el7.x86_64 already installed and latest version
Package binutils-devel-2.23.52.0.1-55.el7.x86_64 already installed and latest version
Package elfutils-devel-0.163-3.el7.x86_64 already installed and latest version
Package elfutils-libelf-devel-0.163-3.el7.x86_64 already installed and latest version
Package newt-devel-0.52.15-4.el7.x86_64 already installed and latest version
Package numactl-devel-2.0.9-5.el7_1.x86_64 already installed and latest version
Package pciutils-devel-3.2.1-4.el7.x86_64 already installed and latest version
Package python-devel-2.7.5-34.el7.x86_64 already installed and latest version
Package zlib-devel-1.2.7-15.el7.x86_64 already installed and latest version
Nothing to do
Preparing...                          ################################# [100%]
    package libdrm-2.4.56-39163.el7.x86_64 is already installed
+++ Intstall complete, adding HotFixes
intel-linux-media-patches-39163/
intel-linux-media-patches-39163/libdispatch_trace.a
intel-linux-media-patches-39163/libdispatch_shared.a
intel-linux-media-patches-39163/README
intel-linux-media-patches-39163/libmfx-tracer.so
intel-linux-media-patches-39163/KMD-patches-for-realtime-threads/
intel-linux-media-patches-39163/KMD-patches-for-realtime-threads/0001-Work-around-to-avoid-reduce-spinning-in-the-userspac.patch
intel-linux-media-patches-39163/KMD-patches-for-realtime-threads/README
intel-linux-media-patches-39163/KMD-patches-for-realtime-threads/0001-Reducing-KMD-polling-on-ioctl-calls.patch
‘intel-linux-media-patches-39163/libdispatch_trace.a’ -> ‘/opt/intel/mediasdk/lib/lin_x64/’
cp: cannot create regular file ‘/opt/intel/mediasdk/lib/lin_x64/’: No such file or directory
‘intel-linux-media-patches-39163/libdispatch_shared.a’ -> ‘/opt/intel/mediasdk/lib/lin_x64/’
cp: cannot create regular file ‘/opt/intel/mediasdk/lib/lin_x64/’: No such file or directory
‘intel-linux-media-patches-39163/libmfx-tracer.so’ -> ‘/opt/intel/mediasdk/tools/tracer/’
cp: cannot create regular file ‘/opt/intel/mediasdk/tools/tracer/’: No such file or directory
+++ HotFixes installed, cleanup

[root@localhost CentOS]#

Regard,

Ran

0 Kudos
1 Solution
Jiandong_Z_Intel
Employee
82 Views

Hi Ran,

First, great to know it works for you.

>> I guess I should not do any update, Right ?

I suggest you do update before install Intel Media Server Studio (MSS).  if you still want do update after install MSS, I think you should uninstall

with script "uninstall_sdk_UMD_CentOS.sh" first, then reinstall MSS.

>> Another question, is media sdk can run on windows host machine with guest machine running the same OS and kernel ?

As I know, the answer is NO, but if you use Linux host machine, maybe you can refer to How to setup Media Server Studio R6 on VT-d

>> I also have a laptop with i5-3210M, according to release notes only 4th and 5th Core are supported, so I can't use media sdk with that machine, Right ?

For Linux is yes, you can't use MSS on  i5-3210M. For Windows I think you can use Intel® Media SDK (https://software.intel.com/en-us/media-sdk), for details you can refer to "System Requirements" in Release Notes for Intel® Media SDK

 

Thanks

Zachary

View solution in original post

9 Replies
rshal2
New Contributor II
82 Views

Hi,

I have managed to solve that with rpm -Uhv

But on doing "yum update" I get the following error in CentOs 7.1:

---> Package perl-Carp-Clan.noarch 0:6.04-10.el7 will be installed
--> Finished Dependency Resolution
Error: Package: intel-linux-media-16.4.2.1-39163.el7.x86_64 (installed)
           Requires: libdrm = 2.4.56-39163.el7
           Removing: libdrm-2.4.56-39163.el7.x86_64 (installed)
               libdrm = 2.4.56-39163.el7
           Updated By: libdrm-2.4.60-3.el7.x86_64 (base)
               libdrm = 2.4.60-3.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Regards,

Ran 

Jiandong_Z_Intel
Employee
82 Views

Hi Ran,

I want to get more details,

Does the error in #2 is happened after you install UMD successful ?

 

Thanks

Zachary

rshal2
New Contributor II
82 Views

Jiandong Z. (Intel) wrote:

Hi Ran,

I want to get more details,

Does the error in #2 is happened after you install UMD successful ?

 

Thanks

Zachary

Hi Zachary,

Yes, yum update does not work well after the installation in gold version.

I assume you can see it in your developmenet station too.

Anyway, I tried to run the samples but I get the following error:

[user@localhost release]$ ./sample_encode_drm h264 -i /home/user/mediasdk/sample_video/test_stream.yuv -o output.h264 –w 720 –h 480 –b 10000 –f 30 –u quality –d3d –hw
Encoding Sample Version 0.0.000.0000

ERROR: Unknown codec

Do you have any ideas what it means ?

Regards,

Ran

 

Jiandong_Z_Intel
Employee
82 Views

Hi Ran,

I want check if your graphic driver is okay in your system.

Can you send the output of following command line ?

$ cat /proc/cpuinfo | grep -i intel

$ lspci -nn | grep -i vga

$ ls -l /dev/dri

$ vainfo

$ uname -r

$ strace $ ./sample_encode_drm h264 -i /home/user/mediasdk/sample_video/test_stream.yuv -o output.h264 –w 720 –h 480 –b 10000 –f 30 –u quality –d3d –hw

 

Thanks

Zachary

rshal2
New Contributor II
82 Views

Hi Jaindong,

Thank you.

It works now, when I first tried the encoder I did copy-paste from the pdf to the shell. It turned out that it copies the "-" as another character, which resulted in demo parser confusion.

Now it works though "yum update" still gives error becuase of wrong dependency in the given rpm from Intel R6:

  I guess I should not do any update, Right ?

This is the information of my cpu:

[user@localhost mediasdk]$ cat /proc/cpuinfo | grep -i intel
vendor_id    : GenuineIntel
model name    : Intel(R) Core(TM) i7-5650U CPU @ 2.20GHz
vendor_id    : GenuineIntel
model name    : Intel(R) Core(TM) i7-5650U CPU @ 2.20GHz
vendor_id    : GenuineIntel
model name    : Intel(R) Core(TM) i7-5650U CPU @ 2.20GHz
vendor_id    : GenuineIntel
model name    : Intel(R) Core(TM) i7-5650U CPU @ 2.20GHz
[user@localhost mediasdk]$  lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1626] (rev 09)
[user@localhost mediasdk]$ ls -l /dev/dri
total 0
crw-rw----+ 1 root video 226,   0 Jan  5 08:31 card0
crw-------. 1 root video 226,  64 Jan  5 08:31 controlD64
crw-rw----+ 1 root video 226, 128 Jan  5 08:31 renderD128
[user@localhost mediasdk]$ vainfo
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.1)
vainfo: Driver version: 16.4.2.1.39163-ubit
vainfo: Supported profile and entrypoints
      VAProfileNone                   :    VAEntrypointVideoProc
      VAProfileNone                   :    <unknown entrypoint>
      VAProfileMPEG2Simple            :    VAEntrypointEncSlice
      VAProfileMPEG2Simple            :    VAEntrypointVLD
      VAProfileMPEG2Main              :    VAEntrypointEncSlice
      VAProfileMPEG2Main              :    VAEntrypointVLD
      VAProfileH264Baseline           :    VAEntrypointEncSlice
      VAProfileH264Baseline           :    <unknown entrypoint>
      VAProfileH264Baseline           :    <unknown entrypoint>
      VAProfileH264Main               :    VAEntrypointVLD
      VAProfileH264Main               :    VAEntrypointEncSlice
      VAProfileH264Main               :    <unknown entrypoint>
      VAProfileH264Main               :    <unknown entrypoint>
      VAProfileH264High               :    VAEntrypointVLD
      VAProfileH264High               :    VAEntrypointEncSlice
      VAProfileH264High               :    <unknown entrypoint>
      VAProfileH264High               :    <unknown entrypoint>
      VAProfileVC1Simple              :    VAEntrypointVLD
      VAProfileVC1Main                :    VAEntrypointVLD
      VAProfileVC1Advanced            :    VAEntrypointVLD
      VAProfileJPEGBaseline           :    VAEntrypointVLD
      VAProfileJPEGBaseline           :    VAEntrypointEncPicture
      VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:    VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:    <unknown entrypoint>
      VAProfileH264ConstrainedBaseline:    <unknown entrypoint>
      VAProfileVP8Version0_3          :    VAEntrypointEncSlice
      VAProfileVP8Version0_3          :    VAEntrypointVLD
      VAProfileVP8Version0_3          :    <unknown entrypoint>
[user@localhost mediasdk]$ uname -r
3.10.0-229.1.2.39163.MSSr4.el7.centos.x86_64
[user@localhost mediasdk]$

Another question, is media sdk can run on windows host machine with guest machine running the same OS and kernel ?

I also have a laptop with i5-3210M, according to release notes only 4th and 5th Core are supported, so I can't use media sdk with that machine, Right ?

Regards,

Ran

 

Jiandong_Z_Intel
Employee
83 Views

Hi Ran,

First, great to know it works for you.

>> I guess I should not do any update, Right ?

I suggest you do update before install Intel Media Server Studio (MSS).  if you still want do update after install MSS, I think you should uninstall

with script "uninstall_sdk_UMD_CentOS.sh" first, then reinstall MSS.

>> Another question, is media sdk can run on windows host machine with guest machine running the same OS and kernel ?

As I know, the answer is NO, but if you use Linux host machine, maybe you can refer to How to setup Media Server Studio R6 on VT-d

>> I also have a laptop with i5-3210M, according to release notes only 4th and 5th Core are supported, so I can't use media sdk with that machine, Right ?

For Linux is yes, you can't use MSS on  i5-3210M. For Windows I think you can use Intel® Media SDK (https://software.intel.com/en-us/media-sdk), for details you can refer to "System Requirements" in Release Notes for Intel® Media SDK

 

Thanks

Zachary

View solution in original post

rshal2
New Contributor II
82 Views

Zachary,

Thank you very much!

Ran

rshal2
New Contributor II
82 Views

Hi Zachary,

I've started using the media sdk samples. I noticed that there is also the tutorial zip, but it seems to be quite the same samples. Is there any  mahor differences between these two packages ?

Regards,

Ran

Jiandong_Z_Intel
Employee
82 Views

Hi Ran,

There is an article https://software.intel.com/en-us/articles/media-sdk-tutorials-for-client-and-server talked about tutorials.

To my understanding like below -

Tutorials: step-by-step through use case examples from simple to increasingly more complex usages, focus on the H.264 (AVC) video codec

MSDK samples: a little more complex than tutorials. support more codec, and it is good performance for run benchmark.

 

Both MSDK tutorials and MSDK samples are helpful for start to use MSDK.

 

Thanks,

Zachary

Reply