Community
cancel
Showing results for 
Search instead for 
Did you mean: 
victor_e_
Beginner
107 Views

multi transcode sample doesnt work with "-la" option

Hi

I have a PC with Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz

I am running the precompiled sample binaries in the following way and this is the output

 

[root@localhost mediasdk_samples_bin]# ./sample_multi_transcode_drm -i::h264 /home/victor/Documents/MediaSDK/content/vq_src.264 -o::h264 /home/victor/Documents/MediaSDK/content/mss_out_5M_u1.265 -hw -la
Multi Transcoding Sample Version 5.0.1604371.71

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
Pipeline surfaces number: 48

Return on error: error code -1, /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK2/work/48803f40a4a4f926/mdp_msdk-samples/samples/sample_multi_transcode/src/pipeline_transcode.cpp      2158


Return on error: error code -1, /home/lab_msdk/buildAgentDir/buildAgent_MediaSDK2/work/48803f40a4a4f926/mdp_msdk-samples/samples/sample_multi_transcode/src/sample_multi_transcode.cpp  172

 

what is the problem?

 

0 Kudos
8 Replies
Surbhi_M_Intel
Employee
107 Views

Hi Victor,

Look Ahead is supported only for AVC encoding.(details are in manual Pg 38 Section 4.9.1)-  You can use other rate control methods like CBR and VBR.

Thanks,
-Surbhi

victor_e_
Beginner
107 Views

Surbhi hello

thanks for your reply

but as you can see from my command line

./sample_multi_transcode_drm -i::h264 /home/victor/Documents/MediaSDK/content/vq_src.264 -o::h264 /home/victor/Documents/MediaSDK/content/mss_out_5M_u1.265 -hw -la

i am encoding the output to h264 (AVC), so what is the problem?

 

Regards,

Victor

Surbhi_M_Intel
Employee
107 Views

I missed the o/p codec and because of your output extension, thought you are doing HEVC transcoding.
Can you please tell us which OS and Media Server Studio Package you are using? We don't have this problem on our systems. 
Couple of things you can try is to-
-Recompile the binaries and try again with same cmd line.
-try without -la option and see if the transcode goes through. (seeing the error, I am assuming this option should definitely work)

Please let us know your findings.

-Surbhi

victor_e_
Beginner
107 Views

Surbhi hello

 

i am using the following package: MediaServerStudioProfessionalEvaluation2015R3

my OS is: CentOS Linux release 7.0.1406 (Core)

i am using the precompiled binaries that came with the Media Server Studio Package

without the -la option the transcoding works

waiting for your reply

Victor

Surbhi_M_Intel
Employee
107 Views

Hi Victor,

Can you please check the kernel version. 
Type "uname -r" on the terminal and please let us know what the kernel evrsion is. This seems like an installation problem, the quickest way to solve this problem would be to reintsall and check.

We are also releasing a new kernel patch soon, will keep you posted. 

Thanks,
-Surbhi

 

victor_e_
Beginner
107 Views

hi Surbhi

the kernel version is:

3.10.0-123.13.2.el7.x86_64

do you mean to re install the media sdk?

 

Thanks,
Victor

Surbhi_M_Intel
Employee
107 Views

Hi Victor,

This is the original kernel of the CentOS, seems like Media Server Studio Kernel RPM wasn't installed. 
Please check the CentOS7 installation procedure in getting started guide -  https://software.intel.com/sites/default/files/managed/12/a9/media_server_studio_getting_started_gui...

After the MSS kernel is installed you should see something similar to below kernel version- 
3.12.28-4.6.29404.MSSr1-default

 -Surbhi

victor_e_
Beginner
107 Views

hi Surbhi

great news, i will start re-installing the MSS

will let you know of the outcome

Thanks,
Victor

Reply