Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sumit_j_1
Beginner
74 Views

openSource i965 based decoder output has artifacts.

HI,

I am working with libVA and opensource vaapi driver  to create Mpeg2 decoder.

But, when i am using open source i965_drv_video.so driver my output has some blocky look. However  if i use media SDK iHD_drv_video.so  there is no such block look in output.

I have attached images and vainfo of my setup. Plz suggest what could be the wrong.

Image

hst_input_frame238.png  ->> input image 

hst_decoded_NUC_Ubuntu_iHD--> decoded by IHD driver --> no blocky look.

{

vainfo-for this setup

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.1)
vainfo: Driver version: 16.4.2.1.39163-ubit

}

hst_decoded_NUC_Ubuntu_15.04--> decoded by i965 driver opensource on NUC machine--> blocky look.

vainfo-for this setup

 
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.0)
vainfo: Driver version: Intel i965 driver - 1.3.0

hst_decoded_Desktop_Ubuntu_12.04--> decoded by i965 drive on desktop machine--> blocky look but relative less compared to i965 on NUC

    libva: VA-API version 0.32.0
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva: va_openDriver() returns 0
    vainfo: VA-API version: 0.32 (libva 1.0.15)
    vainfo: Driver version: Intel i965 driver - 1.0.15

 

Regards,

Sumit Jha

0 Kudos
1 Reply
Surbhi_M_Intel
Employee
74 Views

We have this issue reported in another thread - https://software.intel.com/en-us/forums/intel-media-sdk/topic/607397, closing this one and will be following with customer on that. 


 

Reply