Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
18 Views

sample_decode is not working

Hi

When i open the sample_decode project in VS-2013 and trying to build it, there is an error C1083:Cannot open include file: 'atlbase.h'. No such file or directory.  

When i include the header atlbase.h and link it's lib(atlsd.lib), then there are various linking error. 

I want to debug sample_decode to understand the code. I am using Windows8.1 O.S. , Media SDK: 6.0.0.388, Visual Studio 2013, Intel i3-4150 CPU @3.50GHz.

Kindly help me to solve this issue.

Thank you

0 Kudos
2 Replies
Highlighted
Beginner
18 Views

Hi 

Want to add one thing more, I am using VS 2013 Express Edition. And i am including atlbase.h from VS2010 and linking lib file from VS2010.

Thank you

0 Kudos
Highlighted
18 Views

Hi Mohammad, 

Looks like this issue is more suitable to ask in VS Microsoft forum as it is related to lib linkers in VS and not specific to mediaSDK or samples. But I do have have few quick following suggestions.

  • Visual Studio Express edition does not come with ATL headers such as atlbase.h required by windows template library and including previous VS versions header files might also not work as it could miss adding other related header files. 
  • You mite want to check and update to latest windows driver kit here: https://msdn.microsoft.com/en-us/library/windows/hardware/dn641605(v=vs.85).aspx and follow the workaround, which mentions downloading ATL headers from Visual Studio Extension gallery. 
  • Here is a link to a blog which provides steps on how to  include ATL headers in VS 2013 express edition.

Hope above information helps. For further media related questions, please post your questions in media forum: https://software.intel.com/en-us/forums/intel-media-sdk. It will be easier for us to track and respond. 

Thanks, 

0 Kudos