Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SDeut
Beginner
71 Views

session independence and error_not_supported ..

I'm currently having a problem and wonder if someone could shed a light on how to solve it. According to the docs: "Each SDK session can independently be a software-based session or hardwarebased session." which here unfortunately seems not to be the case. Basically the problems breaks down to an error MFX_ERR_UNSUPPORTED returned by a call to MFXInit (MFX_IMPL_HARDWARE_ANY) function under some special circumstances. These are as follows.

In my application there are two idependent SDK-sessions, one for decoding and one encoding. The decoding session is always setup first and may use Hardware-Support as to the users preference. This works well. Later on an encoder session is being setup and occasionally fails with the above mentioned error if MFX_IMPL_HARDWARE_ANY with MFXInit() is requested. Interestingly this behaviour can _only_ be seen when the previous session (the decoder session) was setup with MFX_IMPL_SOFTWARE _and_ with some special hardware setup as well.

Decoder Session        Encoder Session        MFXInit() result
Hardware                   Hardware                   okay
Hardware                   Software                    okay
Software                    Hardware                   fail (!) <----
Software                    Software                    okay

Hardware Setup:

Intel Core i7 4790 with HD 4600
external GFX-Card with Monitor attached to it
Operating System: Windows 8.1.
libmfx DLL version: 5.14.7.25 and 6.15.5.12

Is this a known issue? Any suggestions how to solve or circumvent the problem? Thank you for your help.

 

0 Kudos
1 Reply
Surbhi_M_Intel
Employee
71 Views

Hi Stephan,

We don't expect such a behavior. Few things we would need to debug this issue -
1. Please check the driver version, install latest drivers if they are too old. Latest drivers for you system can be found here and check the reproducibility of the issue.
2. Can you send us a reproducer code or send the tracer logs to debug the issue. Detail on how to capture tracer logs can be found here - <Installed Folder>\Software Development Kit\tools\mediasdk_tracer
3. To eliminate the possibility that it could be because of the discrete graphics card, can you please remove the external GFX-card and try to reproduce the issue. 
4. Just to confirm again, are you setting the MFX_IMPL to be HARDWARE_ANY or setting to specific HADWARE and any idea if it affects the reproducibility of the issue?

Thanks,
Surbhi

Reply