Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sumit_j_1
Beginner
55 Views

simple_2_decode/sample_5_transcode example fails for MPEG2 video stream

HI All,

I am running Media SDK sample examples. I tried to run simple_2_Decode / simple_5_transcode in default configuration i.e input video in h264 form and output is also in same format. Those two are working fine.

Now, I changed decoder ID,

mfxVideoParams.mfx.CodecId =MFX_CODEC_MPEG2; //MFX_CODEC_AVC;

with  only this change i am not able to run decode/transcode with mpeg2 as input stream.

I am getting error like-

Memory lock failure. src/simple_decode.cpp-198

It runs fine for  first few frame then i am seeing this issue.

Plz suggest am i doing right change from mpeg2 stream or I need to change more in code apart from just changing CODEC_ID.

 

Rgds,

Sumit jha

 

 

 

 

0 Kudos
4 Replies
55 Views

Hi Sumit - If you downloaded the tutorial package, modified the CodecId with MPEG2 from AVC in simple_2_decode, and did a make --> the resulting executable works fine for MPEG2. I just did this and verified as well. In the simple_5_transcode tutorial, you change the codecId for decode and encode (if you want to do mpeg2 transcode that is).

Can you send us information on the system you are using? I tested on MSS R6 CentOS 7.1 (and previously did this on other platforms too). I am surprised you are seeing an issue with changing AVC->MPEG2.

 

55 Views

In addition, can you please send us the following information:

- System config (MSS version, kernel version, OS)

- Exact command-line used.

- More imp, the test stream you used for MPEG2.

sumit_j_1
Beginner
55 Views

HI Sravanthi,

The information which you have asked to share is as follow-

MSS version- 

Media Server Studio Essentials 2015R5.

Kernel Version-

Linux NUC 3.14.5 

OS

Linux, (Ubuntu 14.04.2 LTS)

Commands, after changing -mfxVideoParams.mfx.CodecId =MFX_CODEC_MPEG2;

used-

make

cd _build;

./simple_decode -hw ~/TestVect/opensource/m84_2.mpg  /tmp/m84_mpg.yuv

Mpeg2 streams-http://hubblesource.stsci.edu/sources/video/clips/ . Form here I have downloaded 3 -mpeg2 streams.

Comet Hale-Bopp Nucleus Animation,--worked fine

Hubble Space Telescope Slews from North to South,--didn't work

Monster Black Hole in Galaxy M84 ---didn't worked

I tried to run simple_decode with these files. It worked well with  "Comet Hale-Bopp Nucleus Animation," but failed with other two streams.

To check some memory issue, i tried to run these with "valgrind". I am seeing Invalid read/write in  valgrind output.  Also with - "Comet Hale-Bopp Nucleus Animation" mpeg2 file which worked fine for decode. 

Also with the existing sample_decode for h264 stream, I am seeing invalid read/write and in the end segmentation fault comes on terminal.

I have attached valgrind output.

Regards,

Sumit Jha

 

 

 

 

 

55 Views

Hi Sumit - 

With all your input streams, I was not able to reproduce the issue on the CentOS (7 and 7.1) and platforms HSW and BDW.

I see you are using Ubuntu 14.04 with 3.14.5 kernel and MSS R5. To make sure the MSS installation on Ubuntu is not the problem here, can you please provide the output of "vainfo" ? Also, what is the platform you are working on?

(One of our engineers wrote an article for how to install MSS on secondary OS, whcih includes Ubuntu 14.04 LTB. May be this can also help you - https://software.intel.com/en-us/articles/how-to-setup-media-server-studio-on-secondary-os-of-linux).