Community
cancel
Showing results for 
Search instead for 
Did you mean: 
rui_w_
Beginner
78 Views

some questions about Intel VPP

Hi, when I use vpp to mix the pictures, I got two input streams to mix, but the output picture is just get the first stream and miss the second stream,the param set like :

stream=1.yuv
width=640
height=480
cropx=0
cropy=0
cropw=640
croph=480
dstx=0
dsty=0
dstw=640
dsth=480
framerate=25
fourcc=nv12


stream=2.yuv
width=640
height=480
cropx=0
cropy=0
cropw=640
croph=480
dstx=0
dsty=0
dstw=240
dsth=160
framerate=25
fourcc=nv12

How could this happen? My computer type is thinkpad e431, Graphics Card: Intel(R) HD Graphics 4000 

And This Works well on another computer thinkpad e440 with Graphics Card: Intel(R) HD Graphics 4600

0 Kudos
7 Replies
Jiandong_Z_Intel
Employee
78 Views

Hi There,

Are you run on Windows ?

If so, Can you share log from system_analyzer tool located at (mediasdk/tools/analyzer) ? This will help provide us your system details. 

 

Thanks,

Zachary

rui_w_
Beginner
78 Views

Jiandong Z. (Intel) wrote:

Hi There,

Are you run on Windows ?

If so, Can you share log from system_analyzer tool located at (mediasdk/tools/analyzer) ? This will help provide us your system details. 

 

Thanks,

Zachary

Hi, The sys_analyzer is

无标题1_0.png

Thank you!

Tamer_Assad
Innovator
78 Views

Hi Rui,

 

Apparently it is the driver . Please check up this thread for resolution and solution.

https://software.intel.com/en-us/forums/intel-media-sdk/topic/387309

 

Best regards,

Tamer

rui_w_
Beginner
78 Views

Tamer Assad wrote:

Hi Rui,

 

Apparently it is the driver . Please check up this thread for resolution and solution.

https://software.intel.com/en-us/forums/intel-media-sdk/topic/387309

 

Best regards,

Tamer

Hi Tamer,

I have updated the Intel drivers, but it still can only support HW acceleration 1.11.  Now it works well with two input streams, but when I add another input stream, the output picture lost it.Then it comes an another question:Does HW acceleration version have an effect on the numbers of input streams?

Best regards,

Rui

Tamer_Assad
Innovator
78 Views

Hi Rui,

 

Updated driver will ensure enabling QSV API, while API version availability is subject for Hardware capabilities.

Intel HD Graphics 4000 hardware usually available on 3rd generation Intel core Processor, Intel HD Graphics 4600 available on 4rd generation Intel core Processor. The 4600 hardware supports higher version of QSV API, that is not the same on the 4000 hardware.

 

when I add another input stream, the output picture lost it.Then it comes an another question:Does HW acceleration version have an effect on the numbers of input streams?

This is not supposed to happen, and could be an implementation issue. I suggest you post this in a new thread, and provide additional information, in order to get the best support for this issue.

 

Best regards,

Tamer

rui_w_
Beginner
78 Views

Tamer Assad wrote:

Hi Rui,

 

Updated driver will ensure enabling QSV API, while API version availability is subject for Hardware capabilities.

Intel HD Graphics 4000 hardware usually available on 3rd generation Intel core Processor, Intel HD Graphics 4600 available on 4rd generation Intel core Processor. The 4600 hardware supports higher version of QSV API, that is not the same on the 4000 hardware.

 

when I add another input stream, the output picture lost it.Then it comes an another question:Does HW acceleration version have an effect on the numbers of input streams?

This is not supposed to happen, and could be an implementation issue. I suggest you post this in a new thread, and provide additional information, in order to get the best support for this issue.

 

Best regards,

Tamer

Hi Tamer,

I just run sample_vpp.exe with command line:

sample_vpp -lib hw -scc nv12 -dcc nv12 -composite par.txt -o out.yuv

and the input streams :one is nv12, one is i420 and another is rgb4. The out.yuv file only gets the streams nv12 and i420, and lost rgb4

Best regards

Rui

Tamer_Assad
Innovator
78 Views

Hi Rui,

 

I don't see a reference for RGB stream in the provided command-line arguments.

Please check the sample documentation/readme file.

 

Best regards,

Tamer

Reply