Community
cancel
Showing results for 
Search instead for 
Did you mean: 
hasbullah_p_
Beginner
58 Views

unable to use hardware acceleration (-hw) for sample decode in LINUX

Hi There,

we are running the sample decode (example code provided by intel in intel media server studio essential 2017 R1 running in centOS 7.2.1511 kernel version 3.10.0-514.6.1.el7.x86_64). We are able to run the code with software (-sw) mode but error occur when we use hardware (-hw). the error are as follows:

[centos@localhost release]$ sudo ./sample_decode h264 -hw -i /home/centos/Videos/Simpsons.h264 -r
[sudo] password for centos: 
pretending that aspect ratio is 1:1
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'i965'
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
check here..

Return on error: error code -3,	/home/centos/Downloads/MediaServerStudioEssentials2017/MediaSamples_Linux_2017/samples/sample_decode/src/pipeline_decode.cpp	405


Return on error: error code 1,	/home/centos/Downloads/MediaServerStudioEssentials2017/MediaSamples_Linux_2017/samples/sample_decode/src/sample_decode.cpp	646

 

the driver is loaded successfully as specify below:

[centos@localhost release]$ lsmod | grep i915
i915                 1307079  4 
i2c_algo_bit           13413  1 i915
drm_kms_helper        146456  1 i915
drm                   372540  5 i915,drm_kms_helper
video                  24400  1 i915
i2c_core               40756  11 drm,i915,i2c_i801,snd_soc_rt5640,i2c_hid,i2c_designware_core,i2c_designware_platform,regmap_i2c,drm_kms_helper,i2c_algo_bit,snd_soc_ssm4567

 

the driver info of the system is as specify below:

[centos@localhost release]$ vainfo
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.99 (libva 1.67.0.pre1)
vainfo: Driver version: 16.5.55964-ubit
vainfo: Supported profile and entrypoints
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	<unknown entrypoint>
      VAProfileH264ConstrainedBaseline:	<unknown entrypoint>
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	<unknown entrypoint>
      VAProfileH264Main               :	<unknown entrypoint>
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	<unknown entrypoint>
      VAProfileH264High               :	<unknown entrypoint>
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	<unknown entrypoint>
      VAProfileVP9Profile0            :	<unknown entrypoint>
      <unknown profile>               :	VAEntrypointVideoProc
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileNone                   :	<unknown entrypoint>

 

0 Kudos
0 Replies
Reply