Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12367 Discussions

A problem in (Nios II eclipe)WH menu

Altera_Forum
Honored Contributor I
795 Views

Hello, 

 

I'm a new for FPGA desgin and I have a problem in NiosII. When I go to (Run as), I can't find ( NiosII instruction set simulator ), (Run as) contains only (1 local c/c++ application & Run configuration). Please help me.
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
75 Views

Hi,  

Did you follow a "getting started" guide ? 

Which Nios II IDE version are you using ? 

You may mean that you can't find "Run as NiosII Hardware..." 

Do you right-click on your project to do "Run as" or do you "run as" through top menu ? 

 

In order to run a Nios II on a board, you must first configure the board :  

* by downloading to the FPGA the correct .sof 

* by using "factory config" (or others but one with Nios II CPU) if you are using an Altera development kit 

 

If you are writing your custom software, have you built a BSP (if you are using Qsys or "system library" if you are using SOPC)
Altera_Forum
Honored Contributor I
75 Views

Thank you 'mmTsuchi' for quick reply, 

1-yes 

2- Nios II 11.1 Software for Eclipse 

3-No, I don't have any board, so I want to do my work using simulator 

4-I do right-click on my project to do "Run as". 

5- I am using SOPC and I have built a BSP. 

 

I did all you have mentioned.
Altera_Forum
Honored Contributor I
75 Views

Instead of "run as", go to "run..."

Reply