Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
885 Views

ARM DS-5 Remote Linux Debugging - Failed to connect to the device

Hi all, 

 

I am trying to debug a simple hello world user space level application on an ARM board running a custom flavor of Linux. Gdbserver has been installed on the board, and the RSE is able to connect successfully and browse the filesystem.  

 

I have created a new debug configuration ( DS-5 Debugger -> Altera -> Cyclone V SOC (Dual Core) -> Linux Application Debug -> Download and debug application ), pointing to my RSE connection. When I try to start the debug, I get the following message: 

 

Unable to connect to New_configuration 

Reason: 

Failed to connect to the device 

Invalid host. 

The hostid of this system does not match the hostid specified in the license file 

Feature: altera_ds_debugger_gdbserver 

Hostid: [host id] 

 

The host Id printed in the message is the correct host id for my development machine, not the target ARM machine I am trying to debug the code on. 

 

Does anyone see anything immediately wrong with what I am doing? 

 

Thanks, 

Nick
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
60 Views

By the way, is this an hello world example from one of the design guide?

Altera_Forum
Honored Contributor I
60 Views

your file system store in the SD card? that with a SSH connection enabled? .

Altera_Forum
Honored Contributor I
60 Views

I have a very strong feeling this is some thing to do wit your license, as the fasted test, simply just debug a hello world example.. see if this error still happens,

Reply